NOTE: THIS IS NOT A DUPLICATE QUESTION. It is specific to Foldit.tar.gz and installing this game is done uniquely. There is an askubuntu page answering the question, "How do I install a .tar.gz (or .tar.bz2) file?", but those instructions are for that generic file type. They don't work with this particular game, and in this explanation I've resolved that. Also, I'm an absolute beginner, running Ubuntu 13.01 for only about 2 months now. I'm only barely familiar with the console at this point. Please bear with me. However, what I offer is the simplest and most concise solution to this problem you will find (out of the first 50 or so google results that come up).

1- From your Downloads folder right click the downloaded file "Foldit.tar.gz" and select the option to extract it into any folder you choose. I picked /Public/Foldit in my home folder.

2- The next step is easiest done from the console. Type in sudo apt-get install xclip
which enables you to cut and paste within the game. (It should run without this feature, if you don't want it.) Then type this in to start it sudo xclip

3- Next type in sudo apt-get install libglut3 which is a prerequisite not mentioned on the fold.it site nor in the readme file. (I asked them to change that, but who knows.) If that command didn't work, like it didn't for me, then go to this page to download the libglut3 package, ubuntu packages, which I was then able to install via the software center. There, you should be all set.

4- Before you try to start the game, make sure you're on-line so it can download all the updates and puzzles. The readme file says, "To start the game, run Foldit from this directory." So go into the folder where you put the original download extracted, and double click Foldit. If it doesn't work completely for any reason (like it didn't for me), restart ubuntu, and try this step again. For me, Foldit wouldn't load up some of the puzzles, but on my 3rd try, it worked perfectly and has ever since.

Don't you love it when you wind up answering your own question? Thank you to everyone that showed and interest and/or helped me.

  • 1
    If those instructions don't work, then you should get one or more errors... So, which error(s) did you received? – Radu Rădeanu Apr 18 '14 at 8:47
  • the readme file says, "To start the game, run Foldit from this directory. To enable copy/cut/paste, you must have xclip (not xclipboard) installed." that's the whole thing. when i double click on the Foldit icon, it creates a file initial_run, but nothing else happens. there are no errors reported. i know how to get to that directory via the console, but i have no idea how to run a program that isn't technically installed. – b-girl Apr 18 '14 at 9:23
  • 1
    So, did you installed xclip (from terminal with sudo apt-get install xclip)? – Radu Rădeanu Apr 18 '14 at 9:25
  • 1
    And what if you start foldit from terminal, not with double click from the file manager? Use ./foldit (change foldit with whatever is its name). – Radu Rădeanu Apr 18 '14 at 9:29
  • 1
    I've voted to reopen this; when it reopens please post your solution as an answer! – Jorge Castro Apr 18 '14 at 21:40

thank you, libglut3 doesn't exist (anymore?), install freeglut3 instead... and it worked for me!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.