I've deleted ~/.macromedia and ~/.adobe contents and after a restart chromium can't detect flash plugin. It works just fine in Firefox

I have only "Chromoting Viewer" on chrome://plugins/

chromium-browser 34.0.1847.116-0ubuntu2

I have profile-sync-daemon active (tried stopping it, of course) and broken PolicyKit as in NetworkManager broken after upgrade to Kubuntu Saucy

Does the detection depend on PolicyKit? What else can I do?


6 Answers 6


Chromium 34 in the main repos have started using Aura (early), which does not include support for NPAPI (this is a planned phaseout of NPAPI in Chromium). Therefore, you need to use Pepper Flash to be able to use Flash.

Installing Flash

Ubuntu 14.04 (Trusty) and newer

If you have Trusty, you can just run sudo apt-get install pepperflashplugin-nonfree.

Ubuntu 12.04 (Precise) and newer

If you don't have Trusty, you can use this PPA to install Pepper Flash for any supported Ubuntu version above Precise. Run the following commands to add the PPA and install Pepper Flash:

sudo apt-add-repository ppa:skunk/pepper-flash
sudo apt-get update
sudo apt-get install pepflashplugin-installer

Note that you need to configure Chromium to use Pepper Flash. To do this, open /etc/chromium-browser/default and add the following line to the end of the file on a new line:

. /usr/lib/pepflashplugin-installer/pepflashplayer.sh

Close all windows and re-open.

Updating Pepper Flash (on Trusty)

You can run sudo update-pepperflashplugin-nonfree --status to see what version of Pepper Flash you have installed. If there is a newer version available, you can just run sudo update-pepperflashplugin-nonfree --install.

  • 7
    For Ubuntu 14.04 you don't need to add the ppa. Pepper Flash is in Ubuntu repositories.
    – Elin Y.
    Apr 21, 2014 at 18:50
  • 3
    On 14.04 I closed all chromium windows, but there were still chromium processes in the background. So if this doesn't work, try rebooting your computer (or go kill processes if you know what you're doing).
    – idbrii
    May 6, 2014 at 6:43
  • Do you know the repository for debian?
    – orezvani
    Aug 19, 2014 at 13:22
  • For Debian, pepperflashplugin-nonfree is in the contrib section of wheezy-backports, jessie, and sid. Aug 19, 2014 at 13:59
  • The one in the official repos is not updated. It still has Flash version 13. Use the PPA.
    – To Do
    Oct 13, 2014 at 8:51

I don't know for sure but I found here that Adobe Flash Player support had ended for Chromium from April 2014. I think it is better if you use Firefox Or you could use the Google Chrome rather than Chromium.

  • 3
    I know for sure and I can confirm your answer, google posted that on their blog like 6 month ago, people didn't bother reading the articles that google posted on that, and no one spread the news until now
    – Lynob
    Apr 29, 2014 at 17:46
  • they dropped support for second party extensions at first, like Uget downloader, extensions that few use, and say we will drop support for other plugins later like flash, they sent a warning, that's why immediately after reading that article, I dumped chrome and went for firefox, a browser that doesn't downloaders is as useless of a software for me as it can get, I don't need a browser that doesn't support NPAPI
    – Lynob
    Apr 29, 2014 at 17:51
  • @Fischer read the button of the blog: "April 2014: NPAPI support was removed from Chrome for Linux in release 35."
    – Braiam
    Apr 29, 2014 at 23:52
  • @Braiam that's what I have been saying above, have I missed something?
    – Lynob
    Apr 29, 2014 at 23:57

Chromium dropped support for NPAPI plugins, in favor of their PPAPI. One of them is "Adobe Flash Player" which from April onwards won't work in any version of Chrome/ium. Chrome has the advantage that includes the PepperFlash plugin which is PPAPI so maybe you should use that, or use Firefox in the meanwhile.

  • Last I checked, Chrome still has NPAPI support, since it's not on Aura, but Chromium in Trusty has Aura and so doesn't have NPAPI support. Apr 30, 2014 at 0:28
  • 1
    @saiarcot895 chrome 35 beta removed NPAPI support in Linux, I'm bing future proof with this answer.
    – Braiam
    Apr 30, 2014 at 0:29
  • Yes, that is true, but not the stable branch. Apr 30, 2014 at 0:36
  • @saiarcot895 obviously OP isn't in the stable branch ;)
    – Braiam
    Apr 30, 2014 at 0:51
  • argh. if only chromium's pepperflash didn't crash all the gd time :/ Jan 21, 2015 at 22:28

Ubuntu 14.04

 sudo apt-get install pepperflashplugin-nonfree

worked for me.

  • 1
    Didn't you need to run also the following command: sudo update-pepperflashplugin-nonfree --install?
    – Elin Y.
    Apr 21, 2014 at 18:59
  • No, maybe it was in the postinst script
    – int_ua
    Apr 21, 2014 at 20:23

If nothing works ...

Download Google chrome .deb file from google ,it includes adobe flash player in it .



I have in ~/.profile a setting:

export CHROME_USER_FLAGS="--disk-cache-size=50000000 --media-cache-size=25000000"

that messed up the /etc/chromium-browser/default settings removing that line solved the flash player issue

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .