0

I'm attempting to install PEAR, and other components.. but getting the following.

$ sudo apt-get install php5 libapache2-mod-php5 php5-mysql
Reading package lists... Done
Building dependency tree       
Reading state information... Done
php5-mysql is already the newest version.
php5-mysql set to manually installed.
libapache2-mod-php5 is already the newest version.
libapache2-mod-php5 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php5 : Depends: libapache2-mod-php5 (>= 5.5.11+dfsg-2+deb.sury.org~precise+1) but 5.5.10+dfsg-1+deb.sury.org~precise+1 is to be installed or
                 libapache2-mod-php5filter (>= 5.5.11+dfsg-2+deb.sury.org~precise+1) but it is not going to be installed or
                 php5-cgi (>= 5.5.11+dfsg-2+deb.sury.org~precise+1) but it is not going to be installed or
                 php5-fpm (>= 5.5.11+dfsg-2+deb.sury.org~precise+1) but 5.5.10+dfsg-1+deb.sury.org~precise+1 is to be installed
        Depends: php5-common (>= 5.5.11+dfsg-2+deb.sury.org~precise+1) but 5.5.10+dfsg-1+deb.sury.org~precise+1 is to be installed
E: Unable to correct problems, you have held broken packages.

I've done the instructions found on here , for getting the PPA setup for PHP 5.5 .. and I'm unclear how to proceed.

After attempting the suggested post in these comments:

$ sudo apt-get clean
$ sudo apt-get autoclean
Reading package lists... Done
Building dependency tree       
Reading state information... Done
$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  • I think this has to do with the new LTS dropping tonight.. – Erik Apr 17 '14 at 7:39
0

Make sure that you have run sudo apt-get update before running sudo apt-get install php5 libapache2-mod-php5 php5-mysql because it will update the package lists so that the latest software can be installed.

| improve this answer | |
  • I run update constantly .. Hasnt changed.. Going to download 14.04 LTS and retry this dance. Maybe 12.04 is just too old? – Erik Apr 17 '14 at 14:25
  • some reason, I waited a few hours.. retried sudo apt-get upgrade . finally it took it. – Erik Apr 17 '14 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.