1

I have a small, usually headless media server at home, and I'm attempting to change its primary network interface from wired ethernet to WiFi. To that end, I installed wicd, which seems to be great for configuring the network. However, booting the machine is taking forever because of the infamous "Waiting for network configuration" issue.

I've already changed my /etc/network/interfaces file and changed references from eth0 to wlan0, to no avail.

What strikes me is that I'm seeing something like:

...
Waiting for network configuration...
Waiting 60 more seconds for network configuration
Continuing without network configuration
...
* Starting network configuration daemon wicd         [OK]
...

Can I start wicd before waiting for network configuration? Should I abandon wicd and just edit some config files, and then this will all "just work?"

  • What exactly did you put in your /etc/network/interfaces file? If you want a wireless interface to connect at boot time it is not enough to change eth0 to wlan0 - you need to add an access point SSID and wireless credentials as well. If you do that, then wicd will become superfluous. – steeldriver Apr 17 '14 at 8:49
  • It's quite a pain, but I suppose it should only be a 1 time thing, and then I don't have to keep wicd running all the time. I'll give that a shot. – Chris Keller Apr 19 '14 at 0:32
0

So I've found two approaches to solving this, both outlined on this Debian page:

  1. Continue to use wicd but effectively disable /etc/network/interfaces by leaving only the loopback entries.
  2. Configure wlan0 directly in /etc/network/interfaces and wicd can be removed (as also suggested by steeldriver above).

Edit: I've now tried both, and both worked, but using method 2 was not as hard as I thought! As suggested by the Debian documentation, all I needed was to make sure wpasupplicant was installed (it already was), change the two existing lines in /etc/network/interfaces for the primary network interface to wlan0, and then add two lines, like so:

auto wlan0
iface wlan0 inet dhcp
    wpa-ssid  MyNetworkSSID
    wpa-psk   MySecretPassphrase

I didn't have to enter every single attribute about the network, and I didn't even have to translate the WPA-PSK passphrase to hexidecimal (though I chose to using the wpa_passphrase tool). So with that, I can be more sure that the network will be active at startup, and I can abandon wicd as one more daemon taking up resources.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.