6

Running Ubuntu 13.10 and each time I login, my volume control is reset to 100%. Pulseaudio never saves its state.

I can run pacmd set-sink-volume 0 26000 on the cmd line to set it back to 40%, but it doesn't save state.

I tried adding it to ".profile" in my home directory, but that runs the command before Pulseaudio sets the volume, so it has no effect.

Any ideas on how to fix this?

  • Sailing in same boat let me too know the Solution – Babin Lonston Apr 16 '14 at 14:15
  • Maybe you should install afew other pulse-audio related packages to make it work. Use Synaptic, type pulse audio in the search field, and look for gstreamer pulse audio, libcanberra pulse, paman, pavumeter, pavucontrol, pulse audio esound compat and anything else that you think you could use. Installing sox package could be of help, and you should also look for missing packges that ALSA needs to run properly. Do not install under any circumstances the package called pulseaudio--module-zeroconf. – Taz D. Apr 16 '14 at 15:06
  • Any reason why you wrote this as a comment rather than an answer? – Pretzel Apr 16 '14 at 15:43
4

Someone suggested that I run the command as part of the Startup Preferences (which I didn't know existed.)

Launch the "Startup Applications" and ADD a new Startup Program.

I called it "Set PulseAudio volume" and inserted the pacmd set-sink-volume 0 xxxxx line in the "Command" section.

Done. It works! :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.