After running a simple upgrade I get a crash each time I try to use apt-get. Any command crashes with the same error message :

legaliz_me:~$ sudo apt-get
apt-get: relocation error: /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12: symbol DDDDDDDDDDDDDDDDDDDDDDDDDDDDDFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF_ZNSt6vectorIN3APT13Configuration10CompressorESaIS2_EE13_M_insert_auxEN9__gnu_cxx17__normal_iteratorIPS2_S4_EERKS2_, version GLIBCXX_3.4 not defined in file libstdc++.so.6 with link time reference

Full log : http://pastebin.com/BmTE5erZ

I don't remember adding any crazy edger ppa or anything special with my system. I'm running 14.04 64bits. Is apt broken for any other person?

  • [PLEASE ADD TO COMMENT I JUST NEED CLARIFICATION] Did you recently add any different libraries 32/64 bit? I am not sure if this answer will help you: stackoverflow.com/questions/19386651/…
    – No Time
    Apr 16, 2014 at 14:42
  • The images are not stable yet, wait for the final release.
    – Braiam
    Apr 17, 2014 at 13:40

1 Answer 1


I had some corrupted dependency which may have prevented libc6 from updating. I checked the package version using :

$ dpkg -l apt libc6  libapt-pkg4.12:amd64
  libapt-pkg4.12:amd64       1.0.1ubuntu2 
  libc6:amd64                2.19-0ubuntu6
  libc6:i386                 2.19-0ubuntu6

I checked md5 of those packages and found that libapt-pkg4.12:amd64 was corrupted by comparing with another user.

$ md5sum /usr/lib/x86_64-linux-gnu/libapt-pkg.so.4.12

Fixed it by manually installing libc6 and libapt-pkg4.12 from launchpad .deb packages : libapt-pkg4.12, libc6

sudo dpkg -i libc6_2.19-0ubuntu6_i386.deb libc6_2.19-0ubuntu6_amd64.deb libapt-pkg4.12_1.0.1ubuntu2_amd64.deb 

After I forced the update so the old dependencies got updated

sudo apt-get -f upgrade

And now everything's fine.

  • 1
    To people with similar issues: just to be safe in case the apt package itself is corrupt, you should also download and install the current apt_*.deb for your release. In fact, re-install all binary packages built from the apt source package, that are currently installed on your system. Dec 20, 2015 at 10:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .