9

I would like to maximize windows vertically by double clicking on the horizontal boarder like in Windows. Is there a way to get this behavior in Gnome Shell?

Thanks in Advance

Edit: I forgot to mention that I mean double click.

Like in this Video

2
  • I am unsure what you mean, but: Double-clicking the top window bar in Gnome will maximize the window. However, I am not sure if what you actually want is to resize the window, or want the maximize button back on the top bar? Could you please explain further. – asgerbj Apr 16 '14 at 12:38
  • I do not mean the Titlebar, but the border of the Window. By clicking and dragging the border you can change the window size. That position is meant. – DesertF0x Apr 16 '14 at 19:07
4

TL;DR There is no way to use the border of a window. You can only use the title bar. Open a terminal an use this command:

gsettings set org.gnome.desktop.wm.preferences action-double-click-titlebar toggle-maximize-vertically

Check the settings with:

gsettings get org.gnome.desktop.wm.preferences action-double-click-titlebar

Or you can try the other options:

gsettings set org.gnome.desktop.wm.preferences action-double-click-titlebar OPTION

OPTION – Current valid options are 'toggle-shade', which will shade/unshade the window, 'toggle-maximize' which will maximize/unmaximize the window, 'toggle-maximize-horizontally' and 'toggle-maximize-vertically' which will 'minimize' which will minimize the window, 'shade' which will roll the window up, 'menu' which will display the window menu, 'lower' which will put the window behind all the others, and 'none' which will not do anything.

4
  • Best answer. I wish I could upvote twice! ;-) – Fabby Aug 29 '15 at 21:30
  • @Fabby Than you should give me at least one upvote :P ;) – A.B. Sep 2 '15 at 16:09
  • Oops!!! Forgot! ;-) – Fabby Sep 2 '15 at 22:03
  • 2
    Please keep in mind that due to the following bug, apps with a "Gnome" titlebar (the broad one) won't maximize vertically or horizontally, but always fully: bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1698083 – DMT Mar 29 '18 at 16:27
4

Not for the border, but for the titlebar. gnome-tweak-tool will let you do this:

https://apps.ubuntu.com/cat/applications/gnome-tweak-tool/

For example:

Windows > Titlebar Actions > Middle-Click > select [Toggle Maximize Vertically]

1
  • 1
    Does this only work on some applications? It seems to never work for me. A middle click always fully maximizes. – Randy Cragun Feb 18 '20 at 23:39
3

Here's an alternate approach: If you middle click the square (orange x, grey -, grey square)

enter image description here

then the window will maximize vertically. I've done that a few times on accident. Glad to finally figure out what random key stroke caused that.

2
  • From my point of view, this is the best method/answer. Also, doing it in this manner I don't lose windows minimizing capability middle clicking title bar. – dgonzalez Jun 24 '19 at 8:04
  • 1
    However, not all windows respect this behavior (IntelliJ, Phpstorm and other Java apps for example) – dgonzalez Jun 24 '19 at 8:10
2

I use a keyboard shortcut.

Go to Settings, Keyboard, Shortcuts, Windows. Then change 'Maximize window vertically'. I use Ctrl+.

3
  • I tried this, but the window is still being maximized fully (not only vertically). 15.04 – Jean Jordaan Jul 22 '15 at 20:19
  • worked for me on centos7 – Mark Rajcok Feb 18 '20 at 16:30
  • Works on Ubuntu 19.10. – ali14 Mar 3 '20 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.