I'm using the latest version of Ubuntu, with a Wi-Fi adaptor that Ubuntu detected flawlessly.

When the internet drops out, Ubuntu gives me a notification bubble in the top right of the screen, e.g. "Wireless network, Disconnected". There is no clickable "x" on these notifications and I can't seem to stop them from returning over and over and over, about once every 5 seconds. To make matters worse, I can't access the network settings menu in the top right of the screen, because every time I open the network settings meny, a notification bubble pops up and cancels the menu. This means I can't configure my network, which is what Ubuntu is complaining about.

So, the short question: how can I disable those notification bubbles? Or, what must I do to acknowledge a bubble so that it doesn't pop up again and again and again unless there has been a significant other event?


Try this: Ubuntu disable popup notifications

Then do the opposite to reenable them. I'd post this as a comment, but I'm 4 rep short.


Works beautifully @eyoung100. I put it into a script in case anybody else is interested.

if [ $# -eq 0 ] ; then
    echo "To turn off notifications, type toggleNotify off"
    echo "To turn on  notifications, type toggleNotify on"
    echo "-h print help"
    echo "-t report whether notifications are on or off"
elif [ $1 = "-h" ] ; then
elif [ $1 = "-t" ] ; then
    if test -f $enabled ; then
        echo "notifications are on" 
        echo "notifications are off"    
elif [ $1 = "on" ] ; then
    if test -f $disabled ; then
        echo "Turning on notifications"
        sudo mv $disabled $enabled
elif [ $1 = "off" ] ; then
    if test -f $enabled ; then
        echo "Turning off notifications"
        sudo mv $enabled $disabled
        killall notify-osd
    #to get the help message

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.