6

First of all, my desktop environment is unity. I am using it with 14.04 OS(with all recent updates). I recently installed infinity conky. I installed and followed all the instructions correctly in the readme file provided with the conky. But my conky appears distorted, like this(the background image is my own wallpaper):

enter image description here

As you would have seen there are boxes after the fonts. The fonts seem to overlap from the last status rather than replacing it(for example you can see the time). Also if you look above the analog clock you will see a half visible icon. This means I also have a transparency issue. Also when i run the conky in the terminal I see output as "Unknown varaiable". That output keeps on printing as you can see below:

enter image description here

I attempted configuring the conky with help from the chat room yesterday. This is what I tried:

  • Changed the font to "Ubuntu"
  • Disabled anti-aliasing

Both did not work. Here is .conkyrc file (it is without any edits).

PS: I tried downloading conky manager from here But it is not available for 14.04. Note that I have conky, conkyall, curl installed. Also is this just a problem with unity itself? Don't unity and conky don't go well with each other? Or is it because I am using a developer version OS that I am being confronted with this problem?

Update :- I noticed something recently. The conky doesn't appear distorted when I start it from terminal. But the moment I minimize or close the terminal, or move to another workspace the conky gets distorted as mentioned above. I thought it was running from the terminal that caused the problem and so added the script to startup applications and rebooted. Now the conky appeared without distortion but only until I opened a new window or moved to another workspace. Thus the problem seems to me to be due to unity. But is it really? If it is so, it is because of which particular aspect of unity and which file should I add when I submit a bug report about this?

  • In the own_window_hints list, seems like it should say undecorated, not undecorate. Not sure if it's related at all. – Nattgew Apr 16 '14 at 19:02
  • @Nattgew Sorry but it doesn't help. – VenkiPhy6 Apr 17 '14 at 7:24
  • 1
    I just installed Trusty and I have the same problem. Conky gets blurred over time or if I change the anti-aliasing settings on unity-tweak-tool... so it seems to be an anti-aliasing problem. But I don't know how to fix it. – user270153 Apr 18 '14 at 2:10
12

When own_window_type override is used the distortion is caused. Now to clear the distortion one may use own_window_type desktop in the .conkyrc instead of own_window_type override . But this causes other problems like disappearance of conky when trying to work in the desktop(i.e right clicking, opening a menu from panel etc.). Therefore instead of own_window_type override one may use own_window_type dock . This won't let the conky to disappear when working on the desktop. Also to solve transparency issue one may remove the line own_window_transparent yes and then include the following lines in its place:

own_window_argb_visual yes    
own_window_argb_value 0

Actually ARGB visual can be used for real transparency to avoid the default pseudo transparency. Therefore even if there are icons in the desktop, they will be visible. Note that ARGB visual can take values 0-255 and a higher value means a greater opacity. Thus distortions can be removed and transparency can be adjusted. Thus the problem is solved. Note that the boxes after the fonts issue(mentioned and seen in the above screen shot)can be removed by removing new lines but new lines may be required for other formatting. Therefore one has no other go but to live with the boxes. Also note that the problem with the boxes is only prevalent in unity. Other desktop environments like Cinnamon don't seem to have the issue.

Credits to these sources:-

  1. Conky transparency not working
  2. http://conky.sourceforge.net/config_settings.html
  3. Help from chatroom .
  • 1
    I followed your suggestion to set own_window_type dock it also worked to remove the old frame issue. But then the conky always be on-top of all other windows / applications. Any idea if it can be set as "at-bottom" of all windows? Thanks. – Raymond Leung Apr 19 '14 at 6:04
  • @RaymondLeung I must confess I am not an expert. Its just some googling that helped me! All I can do to help you is give you this link: conky.sourceforge.net/documentation.html – VenkiPhy6 Apr 19 '14 at 10:31
  • 1
    Just to share I got it (always on top) fixed, after reading the setting page here. I un-commented line own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager which was already in the setting file but disable, then it now works and always stays "below" of other windows. :) – Raymond Leung Apr 20 '14 at 18:45
  • 1
    Thanks, type dock and right gap_x and gap_y setting solved it for me. – Bevor May 13 '14 at 18:41
  • 1
    Just like to point out that this solution also works with Ubuntu 16.04 – Twifty Aug 14 '16 at 12:47
1

I had the same problem with 14.04, after some tests I changed : own_window_type override to own_window_type desktop and now conky is working properly.

  • Great! It worked without distortion. But if I create a desktop icon, conky doesnt view it(transperancy issue). Also if I click and drag that icon when I see it half visible(like in the pic above) the conky disappears. Any solution to this? – VenkiPhy6 Apr 18 '14 at 12:52
  • Also I still see boxes after the fonts. Any solution to solve this too will be great! – VenkiPhy6 Apr 18 '14 at 13:04
  • This link helps a lot: askubuntu.com/questions/246776/conky-transparency-not-working – VenkiPhy6 Apr 18 '14 at 13:59
0

I used this tutorial: http://wyldeplayground.net/how-to-remove-conky-shadow-in-14-04/ and conky OK!

  • Please provide context for your link here. This is because links may get dead after some time. See here under "Provide context for links" for further details: askubuntu.com/help/how-to-answer – VenkiPhy6 May 6 '14 at 5:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.