19

I had a fresh reinstall of Lubuntu 13.10 and my USB headset seems to be not working. I looked for solutions in some forums, but these didn't work for me.

My headset is a Genius Wire Gaming headset.

Thank you!

2
  • What exactly does not work, e.g. what have you tried? Have you selected the USB headset as the device to use for playing audio in the sound settings? – LiveWireBT Apr 15 '14 at 9:35
  • How do you set it, i cant find a button like that, can you help me? – user197828 Apr 15 '14 at 19:35
23

Managing soundcards and audio devices

USB and Bluetooth audio devices are individual sound cards, which means that connecting a Bluetooth headset doesn't work like connecting a headset via 3.5mm audio jack, where jack sensing assumes that you want to play audio through the recently connected headset instead of the laptop speakers.

Therefore when adding new audio devices like Bluetooth or USB headsets and speakers as well es new soundcards or audio interfaces, you should check your configuration to make sure that the sound is played by the device you intend to use. The easiest way is via the Sound Indicator in Unity or via System Settings > Sound:

enter image description here

If your new connected device is the Sennheiser BTD 500 USB in this example, then you should check that it is selected in the Play sound through list.

Alternatively you can use PulseAudio Volume Control to manage your sound cards. It provides many more options such as routing only certain streams (sound from applications) to certain devices. Some applications such as VLC (via package vlc-plugin-pulse) also offer to choose the audio device independently.

enter image description here

Related topics and questions

2

This seems to have fixed it for me, http://ubuntuforums.org/showthread.php?t=1813750&p=11096695#post11096695

Determine your sound device order: Code: cat /proc/asound/cards Dell laptop with Logitech USB headset plugged in:

rj@lubuntu:~$ cat /proc/asound/cards  
0 [Intel          ]: HDA-Intel - HDA Intel HDA Intel at 0xdfebc000 irq 21  
1 [Headset        ]: USB-Audio - Logitech USB Headset 
                     Logitech Logitech USB Headset at usb-0000:00:1d.2-1, full speed

sudo leafpad /etc/asound.conf 

Set sound device 1 USB Headset as default:

defaults.ctl.card 1
defaults.pcm.card 1 

File/Save/Quit Reboot

If you use both soundcard/speakers and USB headset: UDEV rule switch's default sound device when USB headsets are plugged in. Software producing sound must be restarted after USB is inserted/removed.

sudo leafpad /etc/udev/rules.d/00-local.rules 

KERNEL=="pcmC[D0-9cp]*", ACTION=="add", PROGRAM="/bin/sh -c 'K=%k;K=$${K#pcmC}; K=$${K%%D*}; echo defaults.ctl.card $$K > /etc/asound.conf; echo defaults.pcm.card $$K >>/etc/asound.conf'"
KERNEL=="pcmC[D0-9cp]*", ACTION=="remove", PROGRAM="/bin/sh -c 'echo  defaults.ctl.card 0 > /etc/asound.conf; echo defaults.pcm.card 0 >>/etc/asound.conf'" 

File/Save/Quit

2

Run

sudo apt install pavucontrol
pavucontrol 

Go to configuration and set all the audio output to off except the USB headset.

1

Open a command line via Ctrl+Alt+T then type: alsamixer and press Enter.

After that you will be promted with the sound devices settings on your PC make sure the headphones are not on mute (or any other device) (OO means not mute MM means mute) you can toggle the values via the m key on your keyboard.

4
  • Nope, doesnt work, i also have installed virtual audio cable on my windows os, maybe a screenshot will help right? i will link it soon – user197828 Apr 14 '14 at 17:57
  • 1 imgur.com/7CCACLf 2 imgur.com/jx8NNCJ 3 imgur.com/Hsq2neQ 1. This is my headset, 2 this is the menu when i open the f6 menu, 3 this when i go to the alsamixer and do nothing – user197828 Apr 14 '14 at 18:12
  • try to go on the third picture and step by step toggle all muted decives start from the end I tottaly had the same problem the answer is from a toggle distance – Dan Apr 15 '14 at 9:24
  • Nope, i will try uninstalling the VAC program, see if it works – user197828 Apr 15 '14 at 17:04
1

For Kubuntu users:

If you want your USB or Bluetooth audio device to be recognized automatically on connection, you need to right-click on KDE sound indicator and select Audio Setup in the menu.

Alternatively, you may open Application Launcher by pressing Alt+F1 and choose System Settings in Computer tab. In Hardware category select Multimedia item. Then select Audio and Video Settings on the left.

You will see the window Settings for the Phonon multimedia framework. On the first tab you can set Device Preference for all software by choosing Audio Playback item, or set preferences for each software type individually. After you connect your USB headset it will appear it the list as Audio Adapter Analog Stereo. Use Prefer button in the bottom right corner to move your device to the top and press Apply. Afterwards, you may close all your applications. When you open them next time they will be using your USB headset to playback audio.

1
  • The problem for me is that the USB headset is not listed at all. – makkasi Mar 20 '19 at 7:29
0
  1. Install pluseAudio in Ubuntu.

    Using Command:

    sudo apt-get purge pulseaudio
    

    and remove fwupd

    sudo apt-get remove fwupd
    
  2. Open it and Setting for Simultaneous devise connected

    With paprefs install paprefs you have access to a virtual output device that enables simultaneous output to all attached sound cards/devices:

    paprefs
    
  3. Then run command combined input/output devise support in Ubuntu.

    gconftool --set --type string /system/pulseaudio/modules/combine/args0 sink_properties=device.description=Combined
    
  4. Go to System Setting > Sound and select Combined options for input/output

    enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.