I upgraded from 10.10 to 11.04 (kernel 2.6.38-9) and now Ubuntu won't fully boot. I get this message:

Gave up waiting for root device.  Common problems:
 - Boot args (cat /proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
   - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT!  /dev/mapper/isw_jhdfjbgej_Volume01 does not exist.  Dropping to a shell!

Which resulted in falling back to a BusyBox shell.

If I do ls -l /dev/mapper I get:

isw_jhdfjbgej_Volume0 -> ../dm-0
isw_jhdfjbgej_Volume0p1 -> ../dm-1
isw_jhdfjbgej_Volume0p5 -> ../dm-2

I tried booting with an older kernel (2.6.35-28) and that worked (except for x because the nvidia drivers weren't build) and did ls -l /dev/mapper and I got:

isw_jhdfjbgej_Volume0 -> ../dm-0
isw_jhdfjbgej_Volume01 -> ../dm-1  # my ext4 partition
isw_jhdfjbgej_Volume05 -> ../dm-2  # my swap partition

So I sudo apt-get purge linux-image-2.6.38-9-common and then reinstalled nvidia-common for 2.6.35-28 (dkms rebuild the module). Then when I rebooted into 2.6.35-28 I got the same /dev/mapper/isw_jhdfjbgej_Volume01 error that I got with 2.6.38-9.

  • fake raids are bad and you should feel bad – crasic May 23 '11 at 23:25

Look at this:


Do you have a promise Raid? If it's so, looks like it fits your problem. There's another entry here about that:


So it's a bug from Ubuntu installation and the dmraid package.

To sum everything, looks like there's a ppa with the update in it:

ppa: psusi/ppa
| improve this answer | |
  • I'm using hardware raid... though I don't know if it's faked or not. I tried this but the problem still remained. – All Workers Are Essential May 25 '11 at 15:53

The solution patch to my problem should have been painfully obvious:

ALERT!  /dev/mapper/isw_jhdfjbgej_Volume01 does not exist 

isw_jhdfjbgej_Volume01 is part of the boot options in grub:

kernel /boot/vmlinuz-2.6.35-28-generic root=/dev/mapper/isw_jhdfjbgej_Volume01 ro splash quiet

For whatever reason upon upgrading isw_jhdfjbgej_Volume01 is now called isw_jhdfjbgej_Volume0p1 (ultimately pointing to /dev/dm-1). So by changing isw_jhdfjbgej_Volume01 to isw_jhdfjbgej_Volume0p1 in the boot configuration, my system booted up properly.

Why the volume's name under /dev/mapper changed, I have no idea.

| improve this answer | |

It might be worth trying to use the live cd upgrade method if not for the first time then again. I know I had trouble after being messing with Gnome 3 and could only get it working again by inserting a live cd in and selecting install, then upgrade from 10.10 which is one of the options? That way as you are upgrading not reinstalling your data is safer.

Do you have much data already on your system and can you back it up. Again if you are unsure, boot up using a live cd/pen drive and navigate into your old home folder and back up what you can first. Then at least if you get stuck you can be sure you have some data backed up. Apologies if you know this already or have already done so.

Let us know how you get on.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.