1

No success mounting a device in read-write mode. After plugging it in, it is mounted.

$ sudo lsblk -o NAME,FSTYPE,SIZE,MOUNTPOINT,LABEL
NAME   FSTYPE    SIZE MOUNTPOINT         LABEL
sda            238,5G                    
├─sda1 ext4    230,6G /                  
├─sda2             1K                    
└─sda5 swap      7,9G [SWAP]             
sdb            931,5G                    
├─sdb1 vfat      200M                    EFI
└─sdb2 hfsplus 931,2G /media/cr/FinnHard FinnHard
sr0             1024M 


$ sudo mount -o remount,rw  '/media/cr/FinnHard'
mount: /media/cr/FinnHard not mounted or bad option


$ sudo umount /media/cr/FinnHard 
$ sudo mount -t hfsplus -o rw  /dev/sdb2 '/media/FinnHard'
mount: warning: /media/FinnHard seems to be mounted read-only.

What am I doing wrong?

1

It looks like you're running into the problem described here. You should be able to mount that volume read/write by running:

sudo apt-get install hfsprogs
sudo mount -t hfsplus -o remount,force,rw /media/cr/FinnHard

You'll be able to mount it again later on using:

sudo mount -t hfsplus -o force,rw /dev/sdb2 /media/cr/FinnHard

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.