26

I am running Ubuntu 10.04, fully updated, from an external USB hard drive. Everything works really well, except the keyboard. The numeric keypad is not working. The keys don't do anything, with or without NumLock on.

The Keyboard Preferences are set for Generic 105-Key (Intl) PC. The keyboard itself, on this computer, is PS2.

Any ideas where to look for trying to fix this?

  • What behavior do you see in the console (Ctrl-Alt-F1)? If they work there, what does showkey report when run in the console? If that behaves properly, what does xev report under X? – msw Sep 21 '10 at 6:01
  • Switched to console, and they didn't work at the beginning. Pressing Num Lock a couple of times made them work. "showkey" also shows reaction, with keycodes 71,72,73...81,82,83... Looks normal. Oooooohhhh... I just solved it. I'll answer my own question below. Thanks for your suggestions, they helped me to notice what was happening!!! – UrkoM Sep 21 '10 at 9:49
34

Sometimes, in machines that I connect through VNC mouse keys get mysteriously enabled. Maybe this is your problem.

Click on the System Menu -> Preferences -> Keyboard. In the Mouse Keys tab check that Pointer can be controlled using the keypad is disabled.

alt text

  • Ooops....!!! That was it! When I found that the keys were working fine in the terminal, it was obvious that the hardware was being detected just fine. Then started testing with xev and noticed that the mouse cursor was moving very small steps. So... thanks for reading! :) – UrkoM Sep 21 '10 at 10:02
  • 1
    Toggle Shortcut: Shift + NumLock – Luigi Siri Jan 20 '14 at 14:09
  • how do i make this change if i'm using icewm? – nnyby Oct 22 '15 at 19:29
17

I'll post another answer because it took me ages to figure it out. It appears that things have been moved around a bit in recent releases. The "Mouse Keys" tab wasn't there in my Keyboard preferences (Ubuntu 11.10, gnome shell), so @JavierRivera's solution set me on the right track, but didn't solve the problem of turning off the "control pointer using keypad" option. This is where I did find it:

Settings > Universal Access > Pointing and Clicking

I also enabled "Numeric keypad keys work as with Macintosh" since I'm using an imac keyboard. This option is found in:

Settings > Keyboard Layout > Layouts > Options > Miscellaneous compatibility options

which seems to be necessary for me.

  • This method works for Ubuntu 12.04-- I didn't have the same menu layout as the accepted answer here (older version of Ubuntu); had the same issue. – papashou Apr 30 '12 at 3:13
5

For Ubuntu 12.10:

  • Click on the System Menu -> System Settings -> Universal Access -> Point and Clicking

  • Turn "Mouse Keys" off

1

If you are using XFCE4 (e.g. Xubuntu):

  • Go to Settings Manager > Accessibility > Mouse
  • Uncheck "Use mouse emulation"; if it is already unchecked, first check it, and then uncheck it (I suppose, for whatever reason, the GUI doesn't know the the Numpad is emulating the mouse)

protected by Community Dec 13 '17 at 5:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.