I am running the latest stable version of Transmission (version 2.31 from the Transmission ppa). Any time I try to log in to the web user interface, I get hit with this:

409: Conflict

Your request had an invalid session-id header.

To fix this, follow these steps:

When reading a response, get its X-Transmission-Session-Id header and remember it Add the updated header to your outgoing requests When you get this 409 error message, resend your request with the updated header This requirement has been added to help prevent CSRF attacks.

X-Transmission-Session-Id: CBcYiodnQIHKYkhr9EceZOMW3ICgMSgt6j2FTCOXbcunA1tK

Anyway, I've had this problem with Transmission for the last couple of versions, and I haven't been able to find an answer as to how to fix this anywhere online. If anyone has any ideas, let me know.

4 Answers 4


What is the URL you're trying to use?

Don't forget the trailing slash http://host:9091/transmission/web/ (it makes all the difference)

  • I don't even have apache installed. In the past, I didn't need to install or tinker with apache at all to get the webui to work. Also, I'm using URL format host:9091/transmission/web
    – Ken
    May 25, 2011 at 10:52
  • sorry, misunderstood. Updated answer.
    – hometoast
    May 25, 2011 at 14:28
  • 8
    Omg, why the trailing slash is so important? I can't beleave that this resolved the problem.
    – KoCMoHaBTa
    Apr 27, 2015 at 5:31
  • 1
    Same here...unbelievable
    – Sampgun
    May 29, 2018 at 7:50
  • @Sampgun It would make a difference if your browser stumbles upon e.g. http://localhost:9091/transmission/web/?action=setsetting&s=password&v=backdoor Apr 16, 2019 at 20:51

Try adding #files to the end of the address. e.g /web/#files.

It worked for me.

I was even able to take the #files off it once I had logged in and it still worked for some strange reason?


I just solved this issue enabling the DMZ server in the router, pointing to the local IP of the raspberry.


fwiw, I read the comment about the slash above and I am using the ttransmission remote gui.

I recentely added far more than my usual number of torrents to a seedbox and started reciving the session ID error and timeout errors as well in the client.

I was, however, able to access the web interface fine (it was just slow). I fixed the remote gui client by locating the URL in the settings and appending a / to the end of /transmission/rpc, so that I had /transmission/rpc/

this made it work normally except for the occasional timeout issues which i think has less to do with a setting and more to do with the sheer load (although it's only pushing 10mb/sec on gigabit down and 5mb/sec up (though that's just my portion if this is a shared box)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .