I've done a fresh install of Natty 11.04. I have a Broadcom BCM4306 wireless network card and it failed to come up. It said no drivers installed.

After a bit of reading, I installed the b43-fwcutter and the firmware-b43-installer. Now it will attempt to connect to the wireless network and asks for the WPA2 password. However after entering the correct password, it still won't connect and after a minute or so, it asks for the password again.

I've checked the additional drivers list as apparently after installation of the b43 driver it should be listed but there is nothing there.

Not sure if it matters but when I was installing I was connected on a USB WIFI. This works without any additional drivers.

Anyone know how to get this card working? Thanks.

  • Was you connected to network when you installed firmware-b43-installer, or just get the .deb from another machine?
    – enzotib
    May 23, 2011 at 13:31
  • I was connected on a USB Wifi.
    – sickgemini
    May 24, 2011 at 2:30

4 Answers 4


I would perhaps re install your drivers which should not take long Do this via a terminal and you should see if anything goes wrong

So in a terminal type the following

sudo apt-get remove b43-fwcutter firmware-b43-installer


sudo apt-get install b43-fwcutter firmware-b43-installer

This should reinstall your wifi driver

Alternatively what I have done is install the other broadcom proprietry driver STA

This was just as easy again via the terminal

Clear out any older files

sudo apt-get remove bcmwl-kernel-source

sudo apt-get install  bcmwl-kernel-source

If you are still being prompted for entering your password make sure that you have enabled your pc to remember the password

  • Thanks. Tried these out but still no luck.
    – sickgemini
    May 30, 2011 at 11:03
  • I had the same problem (the packages were installed successfully but the card didn't work). It turned out it had been blacklisted. Editing one file and rebooting solved the issue. See first answer in this question: askubuntu.com/questions/38327/…
    – egarcia
    Jan 8, 2012 at 19:53

I have an older Gateway laptop with a Broadcom 4306 card. Installed Ubuntu 11.10. The following got my card working:

sudo apt-get install b43-fwcutter firmware-b43legacy-installer

I had this same problem on a Dell Latitude D600. The Dell Truemobile 1300 card (BCM4306 rev 2) would not work. The system listed it as "device not ready (missing firmware)".

After trying several times to install the firmware-b43legacy-installer I found an Intel card and replaced it. Intel card works perfectly without any configuration.

/lib/firmware didn't have a directory for b43legacy and the installer failed saying it didn't have a matching card and that I should use b43 rather than legacy. Looking at the complaints it made, I believe the installer was getting hungup on the Ethernet NIC which is a broadcom BCM5705M but has a PCI ID of 14e4:165d as the error made mention of 14e4:165.

Not sure how to report this issue, but I think it's a problem with the firmware installer package.


Also have a Dell Latitude D600. Everything worked fine after I've installed b43-fwcutter and firmware-b43legacy-installer. My first try was firmware-b43-installer but after configuration a the installer sent a message saying that an unsupported B43 device was found. Then I've removed firmware-b43-installer and installed firmware-b43legacy-installer. Wireless started working right away.

Not the answer you're looking for? Browse other questions tagged .