After a week checking a lot of references about bumblebee/nvidia, I decided to post this new Thread. Nothing I've tried have worked in my scenario :-( ... testing of virtualgl and primus, different choices on config files, rebuilding and testing of drivers nvidia-current-updates and nvidia-331-updates, and installing/deinstalling multiple times ... frustrating. :-( :-/

I will appreciate any hint, tip, or reference which can help me to solve the problems explained below.

HP Laptop. Pavilion 15 Running in legacy mode (by disabling secureBoot) Installed Ubuntu 12.04 (without win8), with bumblebee bumblebee-nvidia virtualgl virtualgl-libs:i386 linux-headers-generic nvidia-331-updates, and additionally primus primus-libs:i386

Current status and results for:

~$ glxgears

Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
305 frames in 5.0 seconds = 60.888 FPS
301 frames in 5.0 seconds = 60.026 FPS


$ optirun -vv glxgears
[  837.155622] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  837.156380] [INFO]Configured driver: nvidia
[  837.156787] [DEBUG]optirun version 3.2.1 starting...
[  837.156840] [DEBUG]Active configuration:
[  837.156896] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  837.156948] [DEBUG] X display: :8
[  837.156980] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-331-updates:/usr/lib32/nvidia-331-updates
[  837.157012] [DEBUG] Socket path: /var/run/bumblebee.socket
[  837.157042] [DEBUG] Accel/display bridge: virtualgl
[  837.157077] [DEBUG] VGL Compression: proxy
[  837.157109] [DEBUG] VGLrun extra options: 
[  837.157145] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[  837.164030] [INFO]Response: No - error: X did not start properly
[  837.164069] [ERROR]Cannot access secondary GPU - error: X did not start properly
[  837.164085] [DEBUG]Socket closed.
[  837.164117] [ERROR]Aborting because fallback start is disabled.
[  837.164131] [DEBUG]Killing all remaining processes.


$ lspci | egrep '3D|VGA'
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
0a:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev ff)


$lspci -k 

After boot...

0a:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev ff)

And after 'sudo modprobe nvidia_331_updates' ...

0a:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)
    Subsystem: Hewlett-Packard Company Device 2166
Kernel driver in use: nvidia
Kernel modules: nvidia_331_updates, nvidia_304, nouveau, nvidiafb

(just look changes from rev-ff to rev-a1 ... !!!)

$ jockey-text -l
kmod:nvidia_304 - nvidia_304 (Privativo, Activado, No está en uso)
kmod:nvidia_331 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Libre, Desactivado, No está en uso)
kmod:nvidia_331_updates - nvidia_331_updates (Privativo, Activado, No está en uso)

All drivers activated but 'not in use'

~$ optirun --status
Bumblebee status: Error (3.2.1): X did not start properly

$ optirun -b none nvidia-settings -c :8
[  525.940758] [ERROR]Cannot access secondary GPU - error: X did not start properly
[  525.940890] [ERROR]Aborting because fallback start is disabled.

$ ldd $(which optirun)
linux-vdso.so.1 =>  (0x00007fffb7bfe000)
libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007facb3bce000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007facb39c6000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007facb3605000)
libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007facb33c8000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007facb31ab000)
/lib64/ld-linux-x86-64.so.2 (0x00007facb3ed7000)

Due to problems on char limits into this form, I post an external link for contents from: bumblebee.conf, xorg.conf.nvidia, Xorg.0.log :


Thanks for paying attention!! Best Regards!! ;-))


I know this doesn't necessarily answer your question about Bumblebee, but you said any hint or tip.

If you're not tied down explicitly to 12.04, you could update to 14.04 and use the nvidia-prime package, which makes use of the Optimus hardware much easier.

You do have to log out/in to switch back and forth between the Intel chip and the nVidia chip, but you'll get your whole desktop on the nVidia card when using it and there's almost no configuration necessary.

Bumblebee is a nice solution but it can sometimes be a pain to set up and I have had a couple issues with particles and other things in certain games.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.