0

I am running: wine 1.6.1 Ubuntu 13.10.

I installed a clean 32 bit .wine prefix, with wine set to act as Win 7 (I have tried xp as well). Then installed xna40 (XNA Framework 4.0) and dotnet40 (MS.NET 4.0).

After that I installed steam using winetricks

"env WINEPREFIX="~/,wine winetricks --no-isolate steam"

Then installed terraria as I normally would. When instillation is finished I'll click play, and for a split second i'll get the Preparing to launch terraria prompt and it goes away and terraria does not launch.

The terminal displays this:

me:dwmapi:DwmSetWindowAttribute (0x8013c, 2, 0x33e554, 4) stub fixme:dwmapi:DwmSetWindowAttribute (0x8013c, 3, 0x33e560, 4) stub fixme:dwmapi:DwmSetWindowAttribute (0x8013c, 4, 0x33e550, 4) stub err:module:import_dll Library mscoree.dll (which is needed by L"C:\Program Files\Steam\SteamApps\common\Terraria\Terraria.exe") not found err:module:LdrInitializeThunk Main exe initialization for L"C:\Program Files\Steam\SteamApps\common\Terraria\Terraria.exe" failed, status c0000135

I have tried re-installing everything multiple times and I cant seem to find anyone who is having this same problem. Help??

0

Always consult WineHQ before installing Windows applications with Wine: a user reported a functioning Wine + Terraria combination here (WineHQ report page).
For security reasons, I'll provide some correct/official links.
Steps:

  1. Install Wine 1.6 and PlayOnLinux;
  2. Run PlayOnLinux to install .NET 4.0 (official Microsoft© page), DirectX 9 (official Microsoft© page) and Steam;
  3. Run Steam to download and play Terraria 1.1.2
  4. If Terraria fails to start another time, restart Ubuntu and copy the missing dlls (those in the error messages at the application startup) in the Terraria executable folder.

Always check the .NET Framework installation, because it must be correct (not failed) to have all the dll (like mscoree.dll) in the right places.

This might be a functioning workaround, only remember that you should always have updated and safe software installed, if possible.

Please comment down here if you need more help and don't forget to press the UP arrow if I helped.
Have a nice day.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.