I've been STRUGGLING to install Ubuntu (as dual-boot with an existing Windows XP installation, on a different drive and partition) for a couple of days now. I've already checked the md5 hash for the downloaded iso and DVD files after burning.

I have several problems that recur with my installation:

  1. At first, my install would go slow as molasses, with only the occasional sluggish sign of activity (DVD/HD lights, etc.) before getting stuck at various points early in the process. I researched and found that often NVidia cards are the culprit (which I have). So I tried the nomodeset option, and that finally seemed to get things going (DVD/HD lights flashing regularly, progress indicator progressing, etc.) But then the install always froze at the "Creating User" step. Per another forum post, I've been trying to redo the process doing a "noquiet" so I can find out exactly which step is causing the issue, but I haven't been able to because...

  2. Now when I try to either boot from the DVD or run the install program, I get the error messages:

    buffer I/O error on device sr1, sector nnnn.

    ata_id[257]: HDIO_GET_IDENTITY failed for '/dev/sr1/': No message of desired type.

    (initramfs) Unable to find live file system.

    At first I thought it was due to the earlier faulty installs: I went back in Windows to clear out the intended Ubuntu partitions (regular and swap). But now I am wondering if this is due to the DVD drive: it appears to freeze during the boot process and not respond in time. A "noquiet" boot-run reveals error messages like "soft resetting link...ata slow to respond...forcing hard reset...etc." As a test, one time I tried to eject the DVD during the process when things got stuck: it would not respond until the boot process finished failing and I was forced to reboot. This is all odd because this DVD drive worked fine previously in attempted installs, and still works fine in Windows XP! And 'nomodeset' does not work for me this time.

Note that my BIOS must be one of the older ones: it has options for enabling "legacy support" for USB, but there are absolutely no menus/options for enabling boot from a USB device, so that workaround is out.

Now my friends and relatives are looking at me cross-eyed for the idea of trying Linux at all (especially since they've had easier times with their MS installs).

  • That error does seem to indicate a problem with either the DVD or the drive.
    – Nattgew
    Apr 11, 2014 at 15:43
  • ...but the drive works fine in XP and worked in earlier install attempts! I also checked all the md5 hashes (both the .iso file and the resulting DVD contents post-burn). As far as installing, I've tried multiple options: noquiet...nomodeset...nolapic...EDD=on (and I'm not sure what that one actually does; it was just suggested)...is there something I'm missing? I REALLY want to avoid creating another DVD if I can help it...but is it possible to have good md5 hashes and the DVD is still bad?
    – Superion
    Apr 11, 2014 at 16:21
  • So it was working at first (with the issues in point 1) but now won't boot at all from the DVD?
    – Nattgew
    Apr 11, 2014 at 16:24
  • Correct...although I had to do some modifications to get that to work...nomodeset was the first one I tried, I believe.
    – Superion
    Apr 11, 2014 at 16:24
  • Suddenly an issue with the DVD sounds like a DVD problem, even if it otherwise seems fine. Unless someone else has an idea, I'd suggest a new DVD, or at least making sure this one is free of scratches/dirt. From my experience, optical drives can be really finicky.
    – Nattgew
    Apr 11, 2014 at 16:32

1 Answer 1


OK everyone, first things first: if you are having consistent trouble with installing Ubuntu via DVD, I advise trying a USB installation. My computer's BIOS did not allow USB as a boot option, so for those users in a similar boat, I would suggest the solution I found: Plop, a special bootmanager that you can burn to CD. After setting your computer to look to your CDrom drive first at system startup for a bootable drive, Plop will engage and allow you to select any input interface (hard drive, USB port, CDrom, etc.) to boot from.

I did this and found I was still having trouble at the "Create User" step when installing Ubuntu, even from USB. I did a bit of research, and I think I saw somewhere that configuring your installation settings to "encrypt your home folder" could cause issues...I'm not sure if that's due to a bug or if it's because of some users' large home-folder size. Anyway, I disabled that option on a second attempt, and amazingly, everything worked like a charm!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.