12

My touchscreen is cracked, so the pointer continuously clicks on the cracked area. That prevents me from using the computer normally.

I have tried the xinput disable 'ELAN Touchscreen' command, and even the one specific to the input number (though it should make no difference), yet whenever I do this, touch is re-enabled after only a few seconds.

Is there some way to disable the screen permanently until I decide to turn it on again (when I finally go to fix it)?

3

4 Answers 4

12

To first find the id of the device use:

xinput -list

From there find the name of the touch screen and then run:

xinput disable DEVICE

where DEVICE is the device name enclosed in quotes or its id.

3
  • 1
    how to reinable? Nov 22, 2017 at 12:57
  • 1
    You can add an alias with alias disable-touchscreen="xinput disable \`xinput --list | grep -i 'touch ' | sed 's/id=//g' | cut -f2\`" enable it with the comand xinput enable DEVICE
    – rubo77
    Jul 9, 2020 at 16:17
  • On Ubuntu 21.04, this enables a magic mode where the operating system crashes instantly the next time you touch the screen.
    – Peter Hall
    Aug 19, 2021 at 15:09
0

I don't have a touchscreen to test it but you could install dconf-editor

sudo apt-get install dconf-editor

And try to disable the touchscreen like I did for my touchpad, there's a dedicated entry for touchscreen, just below touchpad:

enter image description here

3
  • My menu looks quite different in dconf-editor, and there is even no settings-daemon, and I can't find these settings elsewhere in the menu. Nov 4, 2014 at 16:03
  • 1
    @MadsSkjern: Try dconf dump / | grep -C6 touch to find the touch properties Nov 4, 2014 at 16:30
  • 5
    @SylvainPineau The touchscreen only has one setting for orientation-lock
    – Shanteva
    Aug 12, 2015 at 13:15
0

Try the following command, where $usbid is the ID of the USB device you want to disable:

echo -n $usbid | sudo tee -a /sys/bus/usb/drivers/usb/unbind

Or equivalently, run the following command as root:

echo $usbid > /sys/bus/usb/drivers/usb/unbind

You can find the ID of your device by running the following command:

dmesg | tail -20

For me, I had to use usb1:

echo -n "usb1" | sudo tee -a /sys/bus/usb/drivers/usb/unbind

The following article has more information about manual driver binding and unbinding: https://lwn.net/Articles/143397/

5
  • And how to enable it back? Jun 14, 2014 at 21:55
  • @KamilDziedzic use the same command, just replace unbind with bind Jun 14, 2014 at 22:52
  • If it would be so easy then I wouldn't ask :) The problem is that this doesn't work for me. It looks like usb device was bind again but touchscreen doesn't work. Jun 16, 2014 at 11:28
  • Hmm, that is how it works for me (I have a touch screen). Did you read through the article I linked to above? Jun 16, 2014 at 14:46
  • How does one tell the USB ID of the touchscreen? Nov 3, 2014 at 20:54
0

For me, bowmanb's answer to this question solved the problem of how to disable touchscreen drivers in Ubuntu.

(Below story has some keywords for incoming searches, in case other people are having similar problems)

My touchscreen on my Samsung Series 5 isn't cracked, but I had been getting a strange bug randomly off and on for the last few months that I couldn't isolate.

Basically - in Ubuntu 12.04 and 14.04 the mouse would jump to the left side of the screen and start spamming click events.

Very annoying when your dock is on the left side of the screen, and it starts randomly opening a lot of applications. ;)

Anyway - it finally started happening often enough that I isolated the touchscreen as the source of the problem. The above answer fixed it for me!

Not the answer you're looking for? Browse other questions tagged or ask your own question.