23

Is it possible to turn "Software updater" off? It pops up on startup every single time offering new (unwanted) updates. I have tried to set "don't check for updates" and all this kind of stuff in Software updater settings. But it still pops up.

It's annoying, could you advice how to get rid of it?

2
  • what version of Xubuntu ? – landroni Apr 11 '14 at 10:56
  • You can remove it from startup applications list. – Registered User Apr 11 '14 at 11:04
25

One of the easiest way I did to overcome from this problem is that you can remove update-notifier

sudo apt-get remove update-notifier

Please note that, this will remove only the graphic way to do system updates.. You can still do your upgrades using commands or Synaptic :)

You can always reply if you get in any trouble.. :)

8
  • 1
    This is a bit extreme. Simply making sure that it doesn't autostart should suffice in most cases. – landroni Apr 11 '14 at 10:57
  • 6
    Frankly this is the best option. It works, and if you don't need the application, why have it installed at all? Disabling an app you dont plan to use seems silly, just remove it. – triunenature Aug 28 '15 at 21:02
  • 1
    I don't like this answer because the xubuntu-desktop package depends on update-notifier. If you ever apt install xubuntu-desktop you'll get update-notifier right back. – Stephen Ostermiller Oct 30 '17 at 20:13
  • 1
    If you want to complete remove all the update GUIs: sudo apt-get remove update-notifier update-manager – Cerin Mar 22 '18 at 18:36
  • 1
    Yes, xubuntu-desktop depends on update-notifier, but that's not a big issue. xubuntu-desktop is simply a catch-all package to pull in the entire Xubuntu bundle. If you don't want the entire bundle (as would be the case if you're removing update-notifier) removing xubuntu-desktop won't break anything. – David C. Feb 8 '19 at 17:05
4

Go to Settings > Session and Startup > App Autostart and uncheck Update Notifier. Also make sure that no other similar entry (like Synaptic) is enabled in that list. Take note that this will likely disable the automatic updating of the data from the package repositories.

3
  • Thank you, I did it. I didn't unchecked it before because it had a synaptic icon, I overlooked it somehow. I hope it will work! Thank you! – Sebastian Apr 11 '14 at 11:02
  • 1
    I couldn't find a "Session and Startup" option in Ubuntu 16.04.6. Hope this answer could be updated. – Nav Oct 3 '19 at 2:37
  • Remember that there's more than one available GUI environment in Linux so they might call it different things. In "xfce" on Ubuntu 18.04.1 it's called Session and Startup and there's a tab Application Autostart with an "Update Notifier" option. It's out there somewhere! – Mike Robinson Mar 13 '20 at 15:25
3

Alternative CLI solution:

sudo crudini --set /etc/xdg/autostart/update-notifier.desktop 'Desktop Entry' Hidden true;

If you need crudini, then: sudo pip install crudini

2
  • Note that you don't need crudini, you can always edit ini files by hand. – Alexis Wilke Apr 17 at 0:15
  • And the popup appeared, so that was useless, unfortunately. – Alexis Wilke Apr 22 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.