1

I just started using Linux and Lubuntu. It's been several weeks of trial and error, with both breaking things and having to reload the OS several times. Specifically, I have Lubuntu running on a Cubieboard2. I have also connected a sata hard drive, and it's working fine. I can move files to and from it, watch movie files from it using Gnome mplayer. I'm just mentioning this as it may rule out any problems with the hardware.

When I right click on the screen, a menu opens up with the title "Openbox". I think this is something I installed separately using apt-get, but I can't remember now. In the menu there is a selection for 'Accessories->Disk Utility'. When I select it I get the error 'failed to execute child process "palimpset" (No such file or directory)'.

After some searching, it seems this is a component of gnome-disk-manager. I tried removing gnome-disk-manager, then reinstalling it with apt-get install. This didn't solve the problem. I tried 'apt-get install palimpset', but there is no such package.

All I can come up with in Google are vague references, some spelled as palimpsest. Also a mention or two of a software bug. I searched my system for both palimpset and palimpsest, but they are not there.

Can anyone shed some light on this? Even if just the correct keywords to search for.

Some system information:

$ uname -r  
3.4.61+

$ cat /etc/lsb-release  
DISTRIB_ID=Linaro  
DISTRIB_RELEASE=13.04  
DISTRIB_CODENAME=quantal  
DISTRIB_DESCRIPTION="Linaro 13.04" 

This should say Ubuntu somewhere? I need to double check exactly what I have installed...

This is the name of the image I installed: lubuntu-desktop-nand.img

Here is the repository information:

$ cat /etc/apt/sources.list  
deb htetep://ports.ubuntu.com/ubuntu-ports/ quantal main universe  
deb-src htetep://ports.ubuntu.com/ubuntu-ports/ quantal main universe 

===========================================================================

This is an update, with good news. With Google and this site's help I located 2 openbox menu configuration files, called menu.xml. They were located here:

/etc/xdg/openbox/menu.xml  
/usr/share/lubuntu/openbox/menu.xml  

The entries in the first file didn't match the menu that openbox was displaying, but the entries in the second file did.
I changed the section below, in the second file, replacing 'palimpset' with 'gnome-disks':

<item label="Disk utility">
  <action name="Execute">
    <command>palimpset</command>
    <startupnotify>
      <enabled>yes</enabled>
    </startupnotify>
  </action>
</item>

Just some rambling: It's a couple of days later, and I had the thought that maybe there is still a problem somewhere. It doesn't make any sense that the Openbox menu should contain 'default' entries, regardless of whether you have those apps or not. I wondered if, on start up, Openbox looks for a file with information about installed apps, and maybe that file has the wrong information. But that can't be it either, because whatever you write into Openbox's menu.xml file is what you get on the screen. It's all very strange, at least to a newcomer.

Thanks to:
girardengo
help.ubuntu.com/community/Openbox
Thread: Edit desktop context menu in lubuntu? (ubuntuforums.org/showthread.php?t=2197247)
Also the person that helped in editing the post, whose icon has disappeared.

  • maybe you're referring to palimpsest: Disks (also known as gnome-disk-utility or GNOME Disks or palimpsest). if you only need to open the disk utility, type in terminal: gnome-disks – girardengo Apr 11 '14 at 16:43
  • Hello, thanks for the input. Here is the response from the command: /# gnome-disks No protocol specified ** (gnome-disks:860): WARNING **: Could not open X display (gnome-disks:860): Gtk-WARNING **: cannot open display: – user349965 Apr 11 '14 at 16:55
  • Forgot to mention that I double checked the spelling on palimpset. That is the name that appears in the error message. – user349965 Apr 11 '14 at 17:07
  • @girardengo I just realized something. When I posted the response to gnome-disks, above, I was talking to the cubieboard from another computer, via ssh! Of course it couldn't open up a display. Pretty dumb on my part. I just tried it again, from a command window on the cubieboard's display, and got the following error: – user349965 Apr 12 '14 at 2:37
  • "(gnome-disks:863): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus/..alphanumeric_chars.. : Connection refused". Unfortunately now I have already reinstalled a fresh version of Lubuntu, and this last error was from it. The only thing I'm really interested in, is being able to set the spin down time on the hard drive, and not have any options, that don't happen to work, displayed in menus. – user349965 Apr 12 '14 at 2:49
0

Palimpsest Disk Utility, also known as gnome-disk-utility, gnome-disks or Disks) is a udisks graphical front-end included in the gnome-disk-utility package. Disks was previously known as GNOME Disk Utility or palimpsest.

Palimpsest Disk Utility is based on Udisks for operations on the disks while GTK + for graphics, so require D-Bus and ServerX to run.

To change the parameters of the hard disk you can use hdparm. hdparm is a command line utility for the Linux to set and view ATA hard disk drive hardware parameters.

Ie, if you want change spindown:

sudo hdparm -S 25 /dev/sdX 

or

sudo hdparm -S 25 /dev/disk/by_uuid/your_uuid_disk

You can modify the /etc/hdparm.conf to make permanent settings even after reboot.

Refer to man hdparm for a complete list of parameters and more help.

  • Turns out the fresh install of lubuntu did not have gnome-disk-utility, or hdparm. I installed both with 'apt-get install gnome-disk-utility' then 'apt-get install hdparm' and now I have an /etc/hdparm.conf file. The commands you listed are working. The original problem: Openbox menu seems to come with predefined entries. If you don't have those apps, or they point to the wrong app, then you get 'file not found' errors when you click them. To fix things up, I'm looking into the info at ..comunity/Openbox. OrangeTux Thanks for fixing up my post! – user349965 Apr 12 '14 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy