0

I'm trying to write some key stroke combinations into my XCompose to allow for typing cuneiform characters, which are defined in the U+12000 - U+1247F range. I've written other strange symbols into my XCompose file, such as signs of the zodiac and planets etc... and they all work just fine, even with the double Multi_key at the beginning (It's all for my research). Here's an excerpt of the file:

...
# Abbreviating some of the longer ones.
<Multi_key> <Multi_key> <s> <c> <o> <r> <p> : "♏"   U264F   # SCORPIUS
<Multi_key> <Multi_key> <s> <a> <g> <i> <t> : "♐"   U2650   # SAGITTARIUS
<Multi_key> <Multi_key> <c> <a> <p> <r> <i> <c> : "♑"   U2651   # CAPRICORN
<Multi_key> <Multi_key> <a> <q> <u> <a> <r> : "♒"   U2652   # AQUARIUS
<Multi_key> <Multi_key> <p> <i> <s> <c> <e> <s> : "♓"   U2653   # PISCES
# Really, this should be SERPENTARIUS.  All the other signs are in Latin.
<Multi_key> <Multi_key> <o> <p> <h> <i> <u> <c> : "⛎"   U26CE   # OPHIUCHUS

# Cuneiform
<Multi_key> <Multi_key> <C> <a>         : "𒀀" # Cuneiform Sign: A
<Multi_key> <Multi_key> <C> <a> <x> <a>     : "𒀁" # Cuneiform Sign: A x A
<Multi_key> <Multi_key> <C> <a> <x> <bad>   : "𒀂" # Cuneiform Sign: A x BAD

Just to prove that I have the fonts installed to show these signs, I'm attaching a screenshot of Gedit editing this file, showing the appropriate glyphs displaying: Cuneiform in Gedit

When I try to use these key combinations for the cuneiform signs I get no character in either Gedit or Libreoffice (or any other text input program for that matter). I'm not sure what's wrong with the file, I think I've followed the correct syntax, and I have the fonts installed. Does XCompose not supported unicode glyphs at such a high range?

1

The ComposeKey sequences used by Gnome to enter special characters are hard coded into the program.

To use a custom Xcompose file, you will need to use the xim input method.

More information about using the compose key - and using xim to bypass the Gnome hardcodings - is given at ComposeKey in the community documentation.

The Gnome hard coding can be overruled in favour of the original Xwindow Input Method (XIM) by setting the environment variable GTK_IM_MODULE. This can be set in the /etc/environment file, but if the machine has more than one user then it is best set from the home directory on a per user basis by modifying ~/.gnomerc or ~/.Xsession
export GTK_IM_MODULE="xim"

Beyond that, it seems likely that you are essentially correct about the additional problems you are having. Direct Unicode input follows ISO 14755 in specifying only 4 hex digits in the code point and the cuneiform code points have 5 digits. It seems likely that this is also the underlying problem here. It seems that the layout is too complex for the compose key.

To enter cuneiform, I think you could create a custom keyboard layout (rather than using the compose key), but really this seems to require an input method editor rather than a keyboard. Your best option is to create a custom input table that would work with Ibus.

| improve this answer | |
  • 1
    I appreciate your help, but I've done that already, that's how I'm able to type the custom characters I've already entered into my .XCompose file in GTK apps like Gedit and Libreoffice. I'm wondering if it's a bigger problem within XIM? (I just tested it in xterm and wasn't able to type the cuneiform codes, but the zodiac ones were fine) – labarna Apr 10 '14 at 20:29
  • Sorry, I misread a key part of your question. Edited. – chaskes Apr 10 '14 at 21:17
  • Hey, wow thanks for finding ISO 14755. That seems to be the underlying problem. I guess if I really want to see this work I'd have to take it to the developers, maybe see if this issue is going to be addressed in Wayland (it's of pretty minor importance, I realize). – labarna Apr 11 '14 at 21:14
  • Definitely file a bug report with Gnome. I've been studying Akkadian off and on (mostly off ;) over the years and may experiment with making an ibus table. – chaskes Apr 11 '14 at 22:25
  • Got here trying to find a way to use emoji with .XCompose, since it's all mostly high Unicode, too. That being said, did you file the bug about the adherence to ISO 14755? Oddly, not all input methods have a problem with 5 digit input. It seems the issue is not about the input method, but more about libx11, at least according to man 5 XCompose. – wxl Mar 5 '15 at 2:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.