I have recently installed Ubuntu 11.04 on my Macbook and after a few days I am now getting very low sound from the speakers as well a red LED is glowing in the Headphone jack.

The sound is perfect if I connect my headphones but if I use the speakers there is no output. I have also installed Windows and Mac OSX(Triple Boot). The speakers work fine when I use either of them as well as there being no LED.

I have re-installed the Ubuntu but then also the problem is not solved.

FIX : Big thanks to Vonhinten I met him on irc #ubuntu who helped me fixing this issue :)

To get the sound i added : options snd-hda-intel model=mbp55 to /etc/modprobe.d/alsa-base.conf

To turn the Red LED off - try: amixer set IEC958 off

  • Welcome to stackexchange and askubuntu Adwait. Instead of leaving your contact detail in your question (where it is very easily visible to spammers, for example), you should subscribe to any answers posted for your question. – nik May 23 '11 at 7:39
  • Also, please put the answer in a new answer and not in your question. You can then accept it a couple of days later to mark it as accepted (instead of adding [Fixed] to the question title). – htorque May 23 '11 at 19:33

The red LED on your headphone jack indicates mini-TOSLINK is enabled for digital output. Since you do not have this light when booting in other OS and the speakers work fine there, the only interpretation left is -- when booted in Ubuntu something is causing your system to think the TOSLink path is active.

I'd expect your speakers to be quite in Ubuntu while the red light is on.

Have you tried booting your system from a 11.04 LiveCD -- probably the one you installed from?
Check the LED state and the speaker output with that.

  • Thanks for the info :) but even after this, i am unable to fix this issue :( – Adwait Sharma May 23 '11 at 9:01

Ubuntu 11.04 doesn't seem to be much of an upgrade to most of us :\ Try looking at the recently removed history in your Software Center, and look for a library that might be related to audio/drivers/etc. then reinstall it.


I had too low sound and rec light too. Try this.

Now the sound is better, and click on some IEC958 flags - you should shut the red light down.


I just installed the Gnome Alsamixer GUI from the Software Center.

First, I turned the red light (mini-TOSLINK) off by un-checking the box for IEC958. Then, I plugged in my external audio device (headphones) and un-checked the boxes for mute on both speakers.

This worked for my MacBook running Ubuntu 12.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.