(The original title of this post was "Boot Repair doesn't work after April 2014 Windows 8.1 Update" since I wanted to highlight that this is not about the 8.0 -> 8.1 update, but the update for 8.1 that came out in April 2014.)

I'm dual booting Ubuntu 13.10 and Windows 8.1. Today I got the "big" Windows 8.1 Update and now my PC doesn't show GRUB anymore, but boots straight into Windows. I've tried running Boot Repair from Ubuntu on a USB stick, but that doesn't seem to do anything. The system still boots directly into Windows every time.

I'm sure I just need to change some setting in Boot Repair, but I don't want to do that without knowing what I'm doing. :)

Here's my Boot Repair Ubuntu Pastebin thingy:




Now I effed everything up completely.

Since I didn't get an answer here, I tried fiddeling with the Boot Repair options. Now the following message flashes for a second when I start the PC:

Could not open "\EFI\BOOT\fallback.efi": 14
Failed to open \EFI\BOOT\grubx64.efi - 800000000000000E
Failed to load image
Failed to open \EFI\BOOT\MokManager.efi - 800000000000000E
Failed to load image

...just before stopping at this line:

Operating System Not Found

Here's my updated Boot Repair report: http://paste.ubuntu.com/7233853/

marked as duplicate by bain, Eric Carvalho, karel, Richard, Radu Rădeanu Jul 8 '14 at 8:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.