0

I have an issue that's driving me crazy. Running Ubuntu 12.04 on DigitalOcean, I followed this tutorial to set up Postfix, Dovecot, ViMbAdmin and RoundCube:

https://rtcamp.com/tutorials/mail/server/postfix-dovecot-ubuntu/

Everything has been working fine for almost a week so far until suddenly today my incoming mail started getting stuck in the queue. I can see the emails using postqueue -p but they've just been sitting there for over 5 hours.

I am able to send email to other hosts just fine, but I can't receive emails I send to myself either.

In my mail.err log I keep seeing lots of this:

Apr 8 16:10:30 marcusforsberg master[14769]: fatal: master_spawn: exec /usr/lib/postfix/f: Permission denied

But nothing else in the error log, just that line over and over.

The mail.log file keeps giving me this:

Apr 8 15:48:07 marcusforsberg master[5841]: fatal: master_spawn: exec > /usr/lib/postfix/f: Permission denied

Apr 8 15:48:08 marcusforsberg postfix/master[5758]: warning: process /usr/lib/postfix/f > pid 5841 exit status 1

Apr 8 15:48:08 marcusforsberg postfix/master[5758]: warning: /usr/lib/postfix/f: bad > command startup -- throttling

And for each email:

Apr 8 15:46:05 marcusforsberg postfix/qmgr[5770]: 7D40416365E: from=, size=5691, nrcpt=1 (queue active)

Apr 8 15:51:40 marcusforsberg postfix/qmgr[5931]: 7D40416365E: skipped, still being delivered

Running postqueue -f has no effect, nor has resetting the Postfix config (dpkg-reconfigure postfix), restarting Postfix or rebooting the server (this has worked before when e-mail got stuck).

I've spent the better part of the day researching this but I haven't found much useful. The only change done before this started malfunctioning was that I rebuilt my DigitalOcean droplet from a snapshot. Before this, everything was working just fine. I had seen the "Permission denied" errors regularly as well but I was still able to receive email.

Here is my main.cf for Postfix: http://pastebin.com/hrxhkWZ7

And my master.cf: http://pastebin.com/mV9GcUNi

If anyone has any suggestions or links to solutions I have missed, please do let me know. Or if I should share any other configuration files or logs.

Thanks in advance for any help!

(This is a repost of my question on DO, where I haven't had much luck. I hope that is allowed and that this is even a good place for this question... Please let me know otherwise!)

1

Look in master.cf for a transport named "f" there must be a typo there.

The master.cf you pasted don't have it tho. Have you pasted the right one?

  • defer unix - - - - 0 f bounce – Båt Karl Patrik Andersson Apr 10 '14 at 8:42
  • 1
    Remove the f in defer transport. – Båt Karl Patrik Andersson Apr 10 '14 at 8:43
  • Thanks, this does seem to have removed the error, not sure how that got there... Mail is still stuck in the queue, though, now with a new error: Apr 10 11:54:57 marcusforsberg postfix/error[4453]: 31FD2160934: to=<someone@somedomain.tld>, relay=none, delay=12839, delays=12839/0.19/0/0, dsn=4.4.2, status=deferred (delivery temporarily suspended: lost connection with marcusforsberg.net[private/dovecot-lmtp] while receiving the initial server greeting) Could this mean something is wrong in the DNS config? I have been making some changes there but nothing related to mail/MX records. – Marcus Apr 10 '14 at 9:01
  • Try requeue all emails with: postsuper -r ALL – Båt Karl Patrik Andersson Apr 10 '14 at 11:37
  • This does not seem to help, they're requeued with the same message. – Marcus Apr 10 '14 at 11:45
0

In addition to Karl Patrik Andersson's answer which solved the weird error in Postfix's logs, I finally stumbled upon an error in dovecot.log that I had missed:

lmtp(11750): Fatal: Error reading configuration: Invalid settings: postmaster_address setting not given

This is was ultimately stopped email from being sent, since it had worked earlier even with the typo in master.cf. This blog post had the solution: http://projectnotedump.wordpress.com/2013/09/08/our-email-server-is-online/

In 15-lda.conf, the commented line postmaster_address has to be set to something, else this error is caused. Set it to postmaster@mydomain.com and mail started pouring in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.