Firefox on Ubuntu is rendering pages extremely slowly despite having a decent connection. After some googling, I found out that this is probably due to my not having installed my grapic card driver. I attempted to install the default driver, but that didn't work. So I tried installing the one that you can download in the Ubuntu Software Center, but that didn't help either. Finally, I downloaded the "AMD Catalyst™ 13.12 Proprietary Linux x86 Display Driver". I may have run it last night, but I couldn't swear on it. Anyway, after trying to install this driver I get this in response:

"a previous install of the fglrx driver has been detected. Please uninstall the older version before installing this version. Optionally run the installer with --force option to overwrite the existing driver. Forcing install is not recommended. See /user/share/ati/fglrx-install.log for more details.".

After checking /user/share/ati/fglrx-install.log, it tells me the exact same thing. I ran this .run the easy way, by just double clicking it—not by running it in the terminal. How could I either a)uninstall the previous version and try installing the driver again, or b) use the --force command in the terminal? Thanks in advance~


1 Answer 1


I recommend that you uninstall the previously installed driver and reinstall a new driver. First you must generate your xorg.conf file. You can do this by :-

sudo aticonfig --initial

Then you can uninstall the AMD proreitary driver by this command:

sudo aticonfig --uninstall

That should work. If it does'nt work and says something like this:

Uninstaller for AMD Catalyst ™ Proprietary driver, /usr/share/ati/amd-uninstall.sh, does not exist or cannot be found

then go to Software center>Edit>Software Sources...>Additional Drivers. Then select your default open source driver. It will probably be the first option in the window and you must select it. See in this image.Note that the window in the image might not be exactly like yours. This image is from my system with AMD Radeon 5570 HD graphic card.

Note that the image might not be exactly like yours. This image is from my system with AMD Radeon 5570 HD graphic card.

Then you need to restore your Xorg.conf file. Now, use this command:-

locate /etc/X11/xorg.conf.original-* 

It may return several paths like :-


and many others too. Of these, note down the file with the highest number. In the above case it is /etc/X11/xorg.conf.original-1. Now use stat to confirm existence of the file :-

stat /etc/X11/xorg.conf.original-1

Then you must copy it over the existing xorg.conf file:-

sudo cp /etc/X11/xorg.conf.original-1 /etc/X11/xorg.conf

Thus, you can restore your Xorg.conf file. Now reboot your system. You will be using your open source drivers now.

PS:- After uninstalling your old driver you can install your new driver by following the answer I have given in this question.

Credits to the installer notes of AMD website found here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.