I am having the same issue this this person had.

npm installed packages are not accessible

Where the command "express nodepad" does not work. It give an error that "The program 'express' is currently not installed. You can install it by typing: sudo apt-get install node-express" However, I did install it using npm with this command "sudo npm install -g express".

When I did ran "sudo npm install -g express" there were no warnings or errors.

What am I missing? Maybe I'm not express correctly?

I was following along with this tutorial. http://dailyjs.com/2010/11/08/node-tutorial-2/ But where he did "npm install express mongoose jade less expresso" I installed each one separately using a sudo and the -g option.

However, when I get to his command "express nodepad" I get the error. I have also tried to sudo the command and get the message "sudo: express: command not found"

Any help would be greatly appreciated.

  • try this in terminal: sudo apt-get install node-express – mfarid Apr 10 '14 at 19:22

The new version of Express (4.0) does not itself have a bin folder. You have to install express-generator to get the setup functionality.

You are not doing anything wrong. Express has just changed the way it works. Have a look at this answer.

  • Thank you. I already knew that apt-get install node-express would work by installing an older version, so that is what I had done since my post. I just tested installing the express-generator on a test virtual machine and it worked great. I wonder why hours of google-ing never pointed me to the change? Thank you for the answer. – Dustin Ruckman Apr 21 '14 at 15:24
  • Thanks; node.js evolves fast. I'm glad to now see the 4.2.1 long-term support release is out. – Lonnie Best Oct 22 '15 at 4:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.