6

I recently switched my desktop environment from GNOME to Cinnamon. In my terminal, I use tmux and have my prefix key mapped to Ctrl+Space. After the upgrade, Ctrl + Space stopped being captured by tmux.

I tried running xev and get this output when I hit Ctrl+Space:

KeyPress event, serial 37, synthetic NO, window 0x3400001,
root 0x9e, subw 0x0, time 49566192, (609,435), root:(611,505),
state 0x0, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
XLookupString gives 0 bytes:
XmbLookupString gives 0 bytes:
XFilterEvent returns: False

FocusOut event, serial 37, synthetic NO, window 0x3400001,
mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 37, synthetic NO, window 0x3400001,
mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 37, synthetic NO, window 0x0,
keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
       0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

I am running Ubuntu 14.04 (Trusty Tahr), and Cinnamon 2.0.14.

3
  • That looks like Cinnamon has bound that hotkey, maybe for some kind of runner dialog? But seems like you do not see any action of Cinnamon desktop. Did you try to find the hotkey in the configuration of Cinnamon? To test whether it's a runner/launcher or similar, you could manually kill processes of this kind, one by one, testing the keys in between. – Volker Siegel Apr 9 '14 at 23:18
  • The xev output basically says: I see a Left Control key pressed, and then someone else takes the keyboard. That "someone else" is what steels your key. Unfortunately, it's not that easy to find out as one would hope (which has good reasons, though). – Volker Siegel Apr 9 '14 at 23:21
  • I've googled around for this issue with Cinnamon and have found pretty much nothing. I've also looked through all the standard places for system shortcuts and have not found anything that has Ctrl-Space bound. And yes you are correct, I see no action from Cinnamon desktop. – Aaronneyer Apr 10 '14 at 3:17
7

Cinnamon is closely related to GNOME, and there Control + Space is commonly used to switch between key maps for different languages, like US and French.

Take a look at the keyboard setup. There should be a section with a large count of special keyboard options. Somewhere there you can choose another hotkey instead of Control + Space to switch keyboard maps/languages.

If you use just one language, you may just deactivate the function.

The following directions are based on plain GNOME, but it will probably work for Cinnamon too:

The current default virtual keyboard app for GNOME runs at startup and captures Control + Space.

Steps to fix:

  • Right-click the keyboard icon in the GNOME bar.
  • Select Configure → Global Config.
  • Change Trigger Input Method from Control + Space.

From this answer https://stackoverflow.com/a/18924670/3405122

0
2

Another possible explanation is Ubuntu bug #1278569. To fix: ibus-setup

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.