Today I wanted to install Ubuntu 11.04 on my fathers computer, as a dual boot next to Windows XP. It has two SATA HDDs in it. The motherboard is an Asus A8n-SLI SE.

The computer has two drives:

  • SATA 1 (in bios) - 1TB, Windows XP installation.
  • SATA 2 (in bios) - 150GB, empty, the plan is to install Ubuntu on this drive.

When starting the PC with the regular Ubuntu install CD, at the manual partitioning menu only the 1TB harddisk is shown. However, when running "sudo fdisk -l", or checking in GParted, the 150GB drive is shown like it should.

After this I tried uncoupling the 1TB disk. This doesn't help: now in the partitioning menu it doesn't show any hard disks at all.

I thought it maybe was some problem with the regular Ubuntu installer, so I downloaded and burned the Ubuntu 11.04 alternate installer. This however gives exactly the same problem: it doesn't show any hard disks (with only the 150GB disk plugged in). It gives one notice before the partitioning menu however: it says the installer found harddrive(s) with RAID-configuration and it asks if I want to enable those. It doesn't matter whether I choose "yes" or "no" - in both cases, no hard disk shows up in the partitioning menu. In the BIOS, any RAID-configuration is disabled, BTW.

I hope someone can help me with this problem, because I can't think of any next steps.

Thanks in advance!

  • I have the same issue with my WD 320 GB sata drive. I can install Ubuntu 10.10 and also Fedora 14 sees my HDD but not Ubuntu 11.04. It can be a bug in Ubunut 11.04. I appreciate if anybody can help me with this issue. – user23013 Aug 9 '11 at 12:52
up vote 2 down vote accepted

It's quite likely that your HDD has leftovers of a RAID configuration, you can do something like this (on terminal)

sudo dmraid -rE

see some reference here

Have a look at your BIOS settings for your SATA drives.

Does it give you an option of setting "IDE Compatibility Mode"? If so try that.

You mentioned that there is no RAID - was there previously? Maybe try the accepted answer here to confirm.

The ASUS A8N-SLI motherboards have a software RAID configuration screen which is separate from the BIOS Setup screen. In my experience, the onboard RAID controller breaks Linux installation if it's enabled at all. (I have an A8N-SLI Deluxe.)

I tried several different distributions when I first got the machine, and none of them would install without the onboard RAID controller enabled. I was able to turn it off and do software RAID from within Linux (the onboard controller is software RAID anyhow) so I did that. Hopefully this won't break your Windows configuration- I recommend disabling the onboard RAID and then trying to boot into Windows to test this before proceeding.

Parenthetically, this is a very flaky motherboard in other respects. It's very sensitive to power fluctuations (more so than usual, I mean) and it doesn't report its RAM properly (essentially, I can have 2 NICs and 3GB or 0 NICs and 4GB) among other things.

  • Boot Ubuntu from a Live CD or Live USB
  • Open a Terminal (Applications > Accessories > Terminal) and type sudo su
  • Type fdisk -l (note which device is your SATA drive)
  • Type dmraid -E -r /dev/sdY (Replacing Y with your actual device found in step 3)
  • Confirm that yes, you wish to remove the dmraid information
  • Return to the desktop and proceed to run the Ubuntu Installer
  • If all goes well, the Installer should now detect your SATA drive and allow you to install Ubuntu to the SATA disk as usual.
  • That might help ya guys....

Run the live mode of ubuntu first, and format the disk you wish to use.

If there is still major issues with getting the disk to mount or other issues, I would suggest installing and running "testdisk" from the live ubuntu instance. It has helped with many different issues resulting in your same problem. (both finding and fixing the issues)

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.