I have some software packages customised for Ubuntu 10.04, 10.10 and 12.10, but now I have to install them on Debian Squeeze. I have been unable to Google for a mapping between specific Ubuntu and Debian versions. Can someone here help?

Specifically I want to know which Ubuntu version corresponds to Debian Squeeze.

up vote 155 down vote accepted

You can find the Debian version on which your Ubuntu version is based in the file: /etc/debian_version

From 10.04 up to 17.04:

   Ubuntu      |       Debian  
18.04  bionic     buster  / sid   - 10
17.10  artful     stretch / sid   - 9
17.04  zesty      stretch / sid
16.10  yakkety    stretch / sid
16.04  xenial     stretch / sid
15.10  wily       jessie  / sid   - 8
15.04  vivid      jessie  / sid
14.10  utopic     jessie  / sid
14.04  trusty     jessie  / sid
13.10  saucy      wheezy  / sid   - 7
13.04  raring     wheezy  / sid
12.10  quantal    wheezy  / sid
12.04  precise    wheezy  / sid
11.10  oneiric    wheezy  / sid
11.04  natty      squeeze / sid   - 6
10.10  maverick   squeeze / sid
10.04  lucid      squeeze / sid

sid is the development distribution of Debian (sid - testing - stable)

You can find out the contents of the file without installing an entire system by view the sources for the package basefiles on Launchpad.

  • Thanks a lot. Just to be clear, you checked this by booting up live CDs of different versions of Ubuntu and then looking into /etc/debian_version? – xkcd Apr 10 '14 at 10:40
  • @xkcd Only 10.04, the others I had either installed or on VM. – Jacob Vlijm Apr 10 '14 at 11:20
  • My 13.10 Ubuntu Gnome says wheezy/sid when I cat /etc/debian_version... – Rmano Apr 10 '14 at 19:38
  • 2
    @Rmano isn't that what the list sais? sid means the development distribution of debian. – Jacob Vlijm Apr 10 '14 at 19:54
  • 1
    @Rmano, I will update my answer today or tomorrow, including the versions in between + the variant of it (all sid so far) – Jacob Vlijm Apr 10 '14 at 20:43

Unfortunately there is no direct mapping /etc/debian_version as mentioned in Jacob's answer gives a rough idea but it only really reflects one package and said package is a package that is locally modified in Ubuntu so won't be automatically pulled in from Debian.

In particular Ubuntu is often ahead of Debian on core packages like libc6. Trying to install a package built on Ubuntu on a contemporary version of Debian is likely to end up with version errors on libc6.

According to https://superuser.com/questions/407745/wrong-libc6-version-in-debian-squeeze-can-i-go-back Debian squeeze had libc6 2.11 . According to http://web.archive.org/web/20110705212424/http://packages.ubuntu.com/search?keywords=libc6 ubuntu 10.04 lucid also had libc6 2.11 . So the packages for 10.4 lucid are IMO the most likely to work on Squeeze.

Depending on what other libraries your program needs you may well find that a specific build for Debian squeeze is needed.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.