After selecting Install Ubuntu from booting from a USB key it shows the loading Ubuntu screen for about 30 seconds then gives the error initramfs "Unable to find a medium containing a live file system" on a Lenovo Twist laptop.

What is unique about my error is that Ubuntu was installed and running fine on a partition of the my 500 GB Hard Drive. I had an SSD 24GB Cache. I replaced my normal HD with an SSD and installed Windows 8 on it. I then formatted the cache with FAT32 planning on putting Ubuntu on that 24GB. But now I can't boot from the same USB I used before with Linux. My boot order is USB HD, SSD Hard Drive, then Cache.

I have checked the MD5, used multiple tools to make the boot key, made sure I'm booting with AHCI, tried all USB ports, disabled USB 3.0, and tried everything from this bug report:


Also when I type "blkid" from the initramfs it does not show my USB key.

So I'm unable to boot from a Linux live USB key after changing my harddrive.

This question is asked before, but this is different than the others because it's unique to a SSD and the "solutions" to others do not work in this case. There are lots of causes of this error where when installing you get a "Unable to find a medium containing a live file system" but none of the solutions work and I believe this is unique to replacing my HD with an SSD.

  • have you tried 13.10? If it doesn't happen in 13.10 then it's a bug. Just click It affects me in Launchpad so you get notified.
    – Braiam
    Apr 11, 2014 at 13:28
  • Same with 13.10. Along with the newest daily build and the Beta of 14.04.
    – Diesel
    Apr 13, 2014 at 18:26
  • Then is a very serious bug.
    – Braiam
    Apr 13, 2014 at 20:56
  • I am having the same issue with a Lenovo Twist. I have installed Ubuntu in the past but it ruined my Windows 8 installation. I ended up having to purchase Windows 8 and reinstall that. Now at this point I keep getting the same error. I think it has something to do with the BIOS updates I have done in the past. Have you updated your BIOS since?
    – user268632
    Apr 13, 2014 at 23:22
  • Yes I have. I figured it had to do with the ssd but you are thinking bios eh? Did you not replace your hard drive?
    – Diesel
    Apr 14, 2014 at 21:50

1 Answer 1


Taken from here.

Lenovo verified that it's the current BIOS 1.65. Version 1.66 is in development and fixes the problem. We can revert to version 1.62 to temporarily allow Ubuntu to work.

I can verify downgrading to 1.62 fixed it. You can download here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.