0

I am getting the following error while compiling gnome 3 from source. Any idea how to get past the error?

configure: error: Package requirements (colord >= 0.1.8) were not met:

No package 'colord' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables COLORD_CFLAGS
and COLORD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
2

You are missing the colord package. Unfortunately you need to build that one too.

When you let jhbuild run and it complains, open a new terminal and run:

    cd ~/gnome-shell/source/ # or wherever your GS sources are
    git clone git://gitorious.org/colord/master.git colord
    cd colord
    ./autogen.sh --prefix="$HOME"/gnome-shell/install/ # change if you install it elsewhere
    make && make install

This will download, build and (locally) install colord. Then go back to the other terminal and choose the point that runs the configuration phase again (AFAIK the first option).

  • The Darktable PPA,for lcms2 dependency: sudo add-apt-repository ppa:pmjdebruijn/darktable-release sudo apt-get update && sudo apt-get install lcms2* – Ubuntuser May 23 '11 at 8:29
0

I'm sorry I can't give you an answer to fix the problem. But, I also tried installing Gnome 3, and it didn't work on my system. Gnome 3 is very buggy right now, so I would wait a few weeks until it becomes more stable. I'm perfectly fine with using Ubuntu Classic, until either Unity or Gnome 3 become less buggy. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.