35

It appears that the keyboard Layout Options that allow things such as "Swap the Escape key and Caps Lock" have disappeared from the keyboard settings in 14.04 Is there another GUI where they can be set? Or is it back to dotfiles?

3

4 Answers 4

41

Install the GNOME Tweak Tool (gnome-tweak-tool), under the Typing tab there is an option to swap Esc with Caps Lock. This worked for me in Ubuntu 14.04.

gnome tweak tool typing section

5
  • 1
    It would be really cool if you could post a screenshot of the setting.
    – Seth
    Commented Apr 16, 2014 at 20:17
  • It's in "Typing" -> "Caps Key Behavior". Very similar to previous menus. Thank you user268068! dl.dropboxusercontent.com/u/17011409/gnometweaktool.png
    – wujj123456
    Commented Apr 20, 2014 at 8:15
  • 1
    this doesn't work very well (Unity ignores this setting for me). Commented Nov 22, 2014 at 20:04
  • This tool is not default tool in Ubuntu installation so better way exists. Commented Dec 31, 2015 at 20:34
  • 2
    I do not recommend this tool because it is unstable. This answer should not be accepted one. Commented Dec 31, 2015 at 20:41
5

I struggled with this a bit during my last OS setup, and found a solution. On this setup I had to trudge through the Internet again to find. Let me leave it here for future reference.

I am using Ubuntu 14.04 LTS (working with 16.04 too), and this is how I remapped my caps lock to escape:

  1. Open terminal
  2. Open the /etc/default/keyboard file with sudo (eg sudo nano /etc/default/keyboard)
  3. add caps:swapescape to the XKBOPTIONS. After modification the line should like the following

    XKBOPTIONS="caps:swapescape"

Note that I did not try this with the caps:swapescape setting. I used the caps:escape setting; i.e. my modification just remaps caps lock to escape but does not map my escape to caps lock.

My source

4

As I mention in another similar question, the usual way to swap Esc and Ctrl is with the following lines in the ~/.Xmodmap file:

clear Lock
keysym Caps_Lock = Escape
keysym Escape = Caps_Lock
add Lock = Caps_Lock

This should work with all desktop environments (KDE, Gnome) on most common distros (Ubuntu and Debian family, Fedora and RH family).

2
  • 2
    Thanks so much for this. This is a nice change for using Vim. I am in Xubuntu. Adding this config file is much better than installing a whole new program just for one setting as suggested in the accepted answer.
    – jbrock
    Commented Aug 14, 2016 at 17:38
  • I presume this doesn't work on Wayland.
    – Flimm
    Commented Sep 21, 2021 at 8:25
1

Another solution is the one mentioned in this post how to permanently switch caps lock and esc that uses dpkg-reconfigure with a few extra steps but setting "caps:swapescape" in xkb-options

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .