I'm having a hard time with this one. I have an ACER ASPIRE ONE 756 and installed Ubuntu 12.04 LTS on it.

Everything works (with a little tweaking here and there), but unfortunately the build-in card-reader terrebly fails.

I know that the BCM57765/BCM57785 is a combined card-reader / wired-lan 1gbps module. The wired lan works fine, but the card-reader fails. It seems to be recognised, but I can't access any SD card. As it doesn't even recognise it in tools like MountManager, the problem seems deeper than just an auto-mount problem.

Can anyone help me out? I really need this to work, and there seem to be a lot of people having issues with linux and card-readers, but unfortunately I haven't found a solution yet.

LSPCI output:

04:00.1 SD Host controller: Broadcom Corporation BCM57765/57785 SDXC/MMC Card Reader (rev 10)


04:00.1 SD Host controller: Broadcom Corporation BCM57765/57785 SDXC/MMC Card Reader (rev 10) (prog-if 01)
    Subsystem: Acer Incorporated [ALI] Device 0742
    Flags: bus master, fast devsel, latency 0, IRQ 19
    Memory at c0400000 (64-bit, prefetchable) [size=64K]
    Capabilities: [48] Power Management version 3
    Capabilities: [58] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [ac] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [150] Power Budgeting <?>
    Capabilities: [160] Virtual Channel
    Kernel driver in use: sdhci-pci
    Kernel modules: sdhci-pci

DMESG without sdcard inserted:

[    1.192432] sdhci: Secure Digital Host Controller Interface driver
[    1.192436] sdhci: Copyright(c) Pierre Ossman
[    1.192771] sdhci-pci 0000:04:00.1: SDHCI controller found [14e4:16bc] (rev 10)
[    1.192843] sdhci-pci 0000:04:00.1: Invalid iomem size. You may experience problems.
[    1.192955] mmc0: no vmmc regulator found
[    1.193030] Registered led device: mmc0::

Any suggestions?

Best regards,


  • 2
    This seems to be the relevant kernel bug: bugzilla.kernel.org/show_bug.cgi?id=73241 – Magnus Hoff Apr 14 '14 at 18:40
  • 2
  • Dear Magnus, Thanks for your reply. So there seems to be a bug. But is there a way to patch this? Itś been reported almost 2 years ago, so you would expect it to be solved by now... – Parsec Apr 15 '14 at 8:22
  • I have the same problem as you, and unfortunately it doesn't look like it's been solved, although there are some patches floating around. I have a different computer than you, but I think there are some workarounds available for you, if you read the linked launchpad-bug. Try reloading the tg3 module and/or attaching to a device via your ethernet port. That might make it work for you. – Magnus Hoff Apr 15 '14 at 9:31
  • There's also some reading material here: bugs.launchpad.net/ubuntu/+source/linux/+bug/1178131 – Magnus Hoff Apr 15 '14 at 9:31

The workaround from the bug report at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1307674?comments=all works for me, but I needed to change the file name to include the extension .conf, e.g. sdhci.conf.

The modified workaround:

  1. Add the following to /etc/modprobe.d/sdhci.conf:

      options sdhci debug_quirks2=4
  2. Re-generate initrd:

     sudo update-initramfs -u -k all
  3. Reboot or reload sdhci module:

     sudo rmmod sdhci-pci sdhci
     sudo modprobe sdhci
     sudo modprobe sdhci-pci
| improve this answer | |
  • 1
    Awesome, I've been trying to get this working for ages! Naming the file `sdhci.conf' worked for me on Ubuntu 18.04 – Nick Edwards Jan 31 '19 at 8:12

It looks like this is fixed in the latest kernel for 14.04. You may wish to upgrade to Trusty

Source: http://ubuntuforums.org/showthread.php?t=2213128

| improve this answer | |

On another forum I saw this works. Insert SD card and type into terminal as root:

rmmod tg3

modprobe -v tg3

It's not automatic unfortunately - have to type it every time.

| improve this answer | |

Installed Zorin 9 (=Ubuntu 14.04), but the bug still exists. For me, this workaround does the job for my Acer Aspire E1-531 with SD card reader BCM57765/57785 MS of Broadcom Corporation:

Add the command rmmod tg3 to the file /etc/modules as follows:

  1. open terminal

  2. type in terminal cd /etc

  3. type sudo -H gedit modules

  4. add the following command at the bottom of the file rmmod tg3

  5. save the file

  6. log off the computer, put in the sd card in the reader and restart the computer with the card still in the reader. The card should mount and you should see it on your desktop or in your filemanager.

You can also buy a usb card reader to do the job, while we are waiting for the bug to be fixed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.