2

I tried to upgrade from 13.10 to 14.04 (beta2). It was mainly successful, but there was an error concerning libpostproc52. I didn't pay too much attention at the time (I know, bad idea, but there were other things going on). By and large, the upgrade is fine, except I have two problems with package management.

1) with synaptic I get:

E: The value 'saucy' is invalid for APT::Default-Release as such a release is not available in the sources E: _cache->open() failed, please report.

I've cleaned the software sources to only include Canonical & independent sources. With synaptic in non-super user mode, vlc-nox shows as broken.

2) with apt-get -f install, I get:

dpkg: error processing archive /var/cache/apt/archives/libpostproc52_6%3a0.git20120821-4_amd64.deb (--unpack): libpostproc52:amd64 6:0.git20120821-4 (Multi-Arch: no) is not co-installable with libpostproc52 which has multiple installed instances

I think the second is related to some combination of VLC and ffmpeg. I've tried various combinations of -f, clean, remove, etc. with apt-get to no avail.

I can't figure out if these two are related or not, but if I can solve the first problem, then I can probably solve the second.

The real question is who or what is generating the 'saucy' reference in synaptic?

Any suggestions?


problem 1) SOLVED: edit (change "saucy" to "trusty") /root/.synaptic/synaptic.conf

problem 2) SOLVED: "dpkg -P fubar" to delete unruly package; unrelated to 1).

Apparently, I cannot label the title as solved!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.