Hello all and thanks for interest!

Im trying to install x13-arima-seats to be used with Rstudio. There are compiled version for RedHat and source available.

I have followed these steps from the official manual http://cran.r-project.org/web/packages/seasonal/README.html. (links to all packages can be found from this manual because i couldn't add more than 2 links):

To install the stable version directly from CRAN, type to the R console:


seasonal does not includes the binary executables of X-13ARIMA-SEATS. They need to be installed separately from here (Windows, filename x13asall.zip) or here (Linux, filename x13asall.tar.gz). My own compilation for Mac OS-X can be obtained upon request. Download the file, unzip it and copy the folder to the desired location in your file system. Next, you need to tell seasonal where to find the binary executables of X-13ARIMA-SEATS, by setting the specific environmental variable X13 PATH. This may be done during your active session in R:

Sys.setenv(X13_PATH = "YOUR_X13_DIRECTORY")

Anyway im stuck when i should compile extracted "x13asall.tar.gz".

root@t420s:/home/jori/Downloads/x13asall# make
make: *** No targets specified and no makefile found.  Stop.
root@t420s:/home/jori/Downloads/x13asall# ./configure
-bash: ./configure: No such file or directory

i used google and found this: http://iristoolbox.codeplex.com/discussions/528902#post1202601 which use "x13assrc.tar.gz" -package for building.

after modifying makefile.g77 as follow i get the same results

cd /path/to/x13assrc/folder
gedit makefile.g77

FC        = /usr/bin/gfortran # "which gfortran" gives this address
LINKER    = /usr/bin/gfortran

root@t420s:/home/jori/Downloads/x13assrc# make
make: *** No targets specified and no makefile found.  Stop.
root@t420s:/home/jori/Downloads/x13assrc# ./configure
-bash: ./configure: No such file or directory

an additional info from my laptop

root@t420s:/home/jori/Downloads/x13assrc# gcc --version
gcc (Ubuntu 4.8.1-2ubuntu1~12.04) 4.8.1

RStudio: Version 0.98.495
Ubuntu Release 12.04 (precise) 64-bit
Kernel Linux 3.8.0-26-generic

Maybe im missing some very basic things because i have always been able to install all the softwares from different repos. Please help, i need this package for one statistic course.

  • If the makefile is called makefile.g77 instead of the normal Makefile, the error No targets specified... is because the makefile is not being detected. Try make -f makefile.g77 to explicitly specify the makefile to use.
    – chronitis
    Apr 7, 2014 at 7:51
  • Thank you so much @chronitis ! You really made my day! Your answer solved my problem. I will add instructions if someone will have same issues. Thanks very much for a very quickly answer!
    – user266140
    Apr 7, 2014 at 20:54

1 Answer 1


OP posted: I will appreciate all responses!

steps that worked for me:

Download source file (x13assrc.tar.gz) from webpage:


extract it with right click or with dpkg

use sudo and go to to the extractred folder

sudo -i
cd /Downloads/x13assrc

change compiler from makefile.g77

gedit makefile.g77

change 2. and 3. rows to these. save and close. (this step is from link above.)

FC        = /usr/bin/gfortran # "which gfortran" from terminal gives address
LINKER    = /usr/bin/gfortran

run makefile. it should run and show a long list different packages.

make -f makefile.g77

after it's done it is better to move all generated files to another location from downloads. I moved those to /usr/lib/x64_bin_x13. for me it was easier to do with nautilus while sudo still on. move all *.o and x13as files. close nautilus when you are ready.


open rstudio,install "seasonal"-package and load it


tell where those files are

Sys.setenv(X13_PATH = "/usr/lib/x64_bin_x13")

check if everything is ok

> checkX13()
Congratulations! 'seasonal' should work fine!
- the X13_PATH is correctly specified
- the binary executable file has been found
- a test run has been successful

logout sudo and close terminal


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.