38

When I move the VLC player window, I can see the video but when I stop moving it, then it gets back to black.

This happens not only in VLC but with my webcam too, when I use camorama webcam.

0
46

go to ToolsPreferencesVideo and set the output to X11 video output and save it now close and open VLC, and open your video

Edit: If it still doesn't work try setting the output to OpenGL video output as suggested by @Asaf

6
  • This solved the issue for me in VLC. But the issue remains in Totem and Gnome-subtitles. Oct 31 '15 at 8:55
  • Works with tick for "Accelerated video output (Overlay)" on Lubuntu 16.10 with ATI Radeon. Nov 4 '16 at 20:10
  • This removed black screens, but video started to play not smooth
    – Dims
    Jan 1 '18 at 20:26
  • Subtitles stopped after do that, revert to automatic make the subtitles come back
    – deFreitas
    Jan 13 '20 at 1:02
  • It still froze on me, and was even harder to deal with.
    – Andrew
    Jun 7 '20 at 18:41
13

Option 1 below worked for me!

I found this solution at:

http://forums.opensuse.org/english/get-technical-help-here/multimedia/455508-vlc-shows-black-screen-when-playing-movie-files-solutions.html

Scroll down for the solutions:

12-Mar-2011, 05:56 #1 wisepenguin wisepenguin is offline Newcomer

Join Date Mar 2011 Posts 12

Default VLC shows black screen when playing movie files (solutions)

Hello,
With a default 11.4 (64bit) installation, and the one click installer for VLC at VideoLAN - VLC: Free streaming and multimedia solutions for all OS! - if you get a black screen when watching movie files there are 2 solutions.

1)
-> Go to Tools->Preferences->Video
-> Remove the tick for "Accelerated video output (Overlay)"
-> Try and play the movie again, you should now see output.

2)
Download proprietary drivers for your graphics card - I think theres a thread on the forum dedicated to that.
Example, NVIDIA 8600 using the default 11.4 open source drivers (nouveau?) shows a black screen when VLC uses "Accelerated video output".
However, installing the proprietary NVIDIA drivers, VLC will successfully show the movie using "Accelerated video output".

To clarify the default VLC installation with "Accelerated video output" ticked - works with proprietary NVIDIA drivers - and doesn't without.

Thanks

ps. Thanks to the team as my integrated ATI Radeon card using default 11.4 open source drivers works with VLC and "Accelerated video output" ticked. 
2
  • 1
    Couldn't find it, must be deprecated
    – Andrew
    Jun 7 '20 at 18:43
  • 1
    @Andrew option moved to a dropdown under Tools > Preferences > Inputs/Codecs, labelled 'Hardware-accelerated decoding' as of 2021.10.27. Setting this to 'disable' fixed the issue for me on Kubuntu 21.04 Oct 28 at 2:16
2

Switching off dpms is the Problem. Try in terminal xset -dpms so the energy saving mode of the screen is disabled.

Switching it on an off results in a flash xset +dpms and xset -dpms. Every time vlc changes video, it calls this function.

2

I found this: https://www.vlchelp.com/stop-hd-video-from-freezing-vlc

Its 3 recommendations are:

  1. Tools->Preferences->Video->Output (if in Advanced mode, I have to click Output Modules), then try setting it to either DirectX (DirectDraw) or OpenGL (X11, as another answer suggested, did not fix it for me).

  2. Tools->Preferences->All Settings->Input/Codecs->Video Codecs->FFmpeg, and set Skip the loop filter for H.264 decoding to All and Hardware decoding to Disable.

  3. (I doubt this will fix any freezing - and I have this problem even with this already set high - but it might help if you're getting skips.) Tools->Preferences->All Settings->Input/Codecs->scroll down to Advanced, and increase the Caching options (e.g. File, Disc, and Network). Personally, for File and Disc Caching, I recommend somewhere around 3000 +- 2000 ms (in other words: somewhere between 1000-5000 ms, which equates to 1s-5s). You'll have a slight delay when you play or pause, but it's worth it to stop any skipping.

1
  • 1
    My VLC was all black from the start of any video file but the sound was there. I followed Andrew's step 1 (didn't help alone) and step 2, then I paused the video, then clicked Media -> Quit and now it works. Maybe it was step 2, maybe it was the pause and quit via menu. Thanks anyway!
    – J. Unkrass
    Aug 26 '20 at 13:22
1

If using Version 3.0.3 Vetinari of VLC Media Player on Windows 7 Professional:

Go to "Tools" - "Preferences" - "Video" - "Output" and change from "Auto" to "OpenGL video output for Windows".

When closing your movie, first pause it & then go to "Media" then "Quit" without selecting the "Stop" button. For some reason, using the "Stop" button sometimes causes the player to crash in Windows 7 Professional.

Worked for me - no more black screen.

2
  • 3
    What's windows 7 have to do with this place?
    – doug
    Jun 2 '18 at 22:34
  • The Media -> Quit after pausing the video might have worked for me. Unfortunately I cannot reproduce the error now to confirm.
    – J. Unkrass
    Aug 26 '20 at 13:25
0

Try checking your video drivers. Reinstall VLC, and your webcam application. But, it does sound like it's your video drivers, so look up some info on your drivers and try to update them.

0

This is my solution:

Black screen when playing a movie in VLC player in Kubuntu 12.04 - Ask Ubuntu Black screen when playing a movie in VLC player in Kubuntu 12.04

I have had to employ this solution twice in the last year, and it has worked both times.

-1

Try disabling compiz/desktop effects.

1
  • Can you elaborate on how to disable compiz, this is not enough information to solve the problem.
    – Mateo
    Aug 14 '12 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.