0

Today package manager suggested the usual updates and I installed everything. After it prompted for reboot, Ubuntu restarted in command line mode. Not sure what to do here. By browsing the forum it seems as though this might have to do with NVIDIA drivers. I tried "startx" (black screen with flashing cursor on top left), and Ctrl-Alt-F1 (nothing happens). I also tried to reboot in failsafeX graphic mode but I get the following error: Fatal Server Error No screens found Server terminated with errors

Not sure where to go from here. I need to get back in graphical mode ASAP and I'm OK with a faster solution even w/o NVIDIA drivers. Any help would be appreciated.

Edit: just clarifying that a) I can log on from terminal and b) I am assuming this is an Nvidia issue but have no certainty.

  • Try re-installing the nvidia drivers. – David M. Sousa Apr 6 '14 at 16:59
  • Already tried to no avail – user263961 Apr 6 '14 at 17:02
  • Tried different drivers from the NVIDIA site and that fixed the issue – user263961 Apr 6 '14 at 20:56
1

Tried different drivers from the NVIDIA site and that fixed the issue. EDIT to provide more detail: Drivers downloaded from NVIDIA site here. Just picked my card and Linux version of drivers. Then from command line I executed:

sudo service lightdm stop

sudo sh drivername.run

Followed driver instructions

sudo service lightdm start

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.