After a botched Gnome 3 install I managed to revert back to classic and everything seems to be working fine. Everything, that is, aside from Evince. I was trying to open a PDF file and Evince just refused to open; I clicked on it, it would load, then stop loading and would no longer appear in the system monitor. I then tried opening it from the terminal, and this error came up:

evince: error while loading shared libraries: libevdocument.so.3: cannot open shared object file: No such file or directory

So I went to synaptic and searched for "libevdocument" and found libevdocument3 installed (version 3.0.0-0ubuntu1~build1) which I attempted to mark for reinstallation, but that option was greyed out, so I tried to completely remove but then it warned gnome-core, libevview3, evince and ubuntu-desktop would be removed. And that sounded bad so I didn't do that. The same happened for uninstall. So now I'm stuck unable to view PDF files. I'm about to install Adobe Reader, but I'd really rather stick with Evince. Any suggestions?

2 Answers 2


gnome-core and ubuntu-desktop are meta-packages that don't contain files themselves, but depend on other packages. So uninstalling them won't cause any issues, especially since you can reinstall them when you reinstall libevdocument3.

Or you could do it the other way and uninstall the packages you mentioned and then reinstall ubuntu-desktop and gnome-core and due to their dependence on evince, it and libevdocument3 would be reinstalled.

  • Cheers! That worked like a charm!
    – Ben Elgar
    May 22, 2011 at 8:14

can you try

sudo aptitude reinstall libevdocument

Does that install the gnome2 version of libevdocument?

  • I just ran that and I got the following: Couldn't find package "libevdocument". However, the following packages contain "libevdocument" in their name: libevdocument3 libevdocument-dev
    – Ben Elgar
    May 22, 2011 at 7:45
  • can you tell me whats the output of "apt-cache show evince" May 22, 2011 at 8:23
  • I'm afraid I fixed the problem by just removing libevdocument3 anyway and then installing it again, along with all the dependencies it removed. Thanks for your help though! :) Ok I tried to post it anyway and it wouldn't let me, but I suppose it doesn't matter since I completely removed it.
    – Ben Elgar
    May 22, 2011 at 10:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .