I recently installed Ubuntu 13.10 on my Lenovo Thinkpad L540. It has problem with the wifi connection. When just booted it works then suddenly it drops the connection and cannot even see the wifi networks.

  • I tried to install the windows driver for the wireless card Intel 7260 but I'm not able to extract the .inf file from the .exe that I download from Intel website. With the .inf file I should then be able to install the driver using ndiswrapper but, since I cannot get the .inf file, this way is gone.

  • I tried also following other ways. I upgraded the Kernel to the 3.13 from 3.11 but still it doesn't work.

  • I tried also to follow instructions such as those from Intel wireless 7260 driver crashes, how do I work around it? but every time I give the command sudo modprobe -r iwlwifi I get:

    FATAL: Module iwlwifi is in use.


  • The command sudo modprobe -rf iwlmvm before sudo modprobe -r iwlwifi, doesn't change the situationi. Still the output to the second command is

    FATAL: Module iwlwifi is in use.

  • The output to uname -r is


  • The output to dmesg | grep iwl is a long list made of elements like the following

    [ 2028.111303] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S

    plus some few exception lines which give

    [ 2031.232825] iwlwifi 0000:02:00.0: RF_KILL bit toggled to enable radio.

  • Please try: sudo modprobe -rf iwlmvm. It will take iwlwifi away with it. Please edit your post to include: dmesg | grep iwl and also: uname -r Thanks. – chili555 Apr 5 '14 at 14:02
  • @chili555 : I also tried your own answer from askubuntu.com/questions/331667/… , but still I wasn't lucky. – Marce Apr 6 '14 at 23:41
  • We need to see that long list of elements in order to diagnose what's going wrong. Please run: dmesg | grep iwl > wifi.txt and also: lspci -nn >> wifi.txt. Find the file wifi.txt in your user directory and paste it here: paste.ubuntu.com Give us the link in your reply. – chili555 Apr 7 '14 at 13:40

I have a different laptop, but the same card and the same problem. The network connection fails after about 5 minutes. You can temporarily restart it by disabling then re-enabling wifi. Then after another 5 minutes it fails again.

Look in /var/log/syslog to see if you have an error like this:

WARNING: CPU: 3 PID: 76 at /build/buildd/linux-3.11.0/net/mac80211/util.c:1538
followed by a stack trace. There appears to be a bug in the Intel 7260 driver that causes the network connection to crash, although it still says it is up. The cure is to upgrade the kernel, but via an upgrade to the operating system. I upgraded to Ubuntu 14.04 and my kernel is now 3.13.0-24-generic and the problem has gone away. Ubuntu 13.10 to 14.04 upgrade instructions are here: http://www.ubuntu.com/download/desktop/upgrade

If your network connection fails after 5 minutes as mine does it may take quite a few goes before you download all of the necessary files. But keep repeating the instructions you find there until it works.

  • I upgraded to 14.04 and nothing improved. I also tried with a fresh ubuntu 14.04 install, and still the wifi connection fails after few minutes. Any other suggestion? – Marce Jun 11 '14 at 15:46
  • Is it possible to change the wifi card in a Laptop? which one should I go for in case? – Marce Jun 11 '14 at 15:46

Just wanna throw this out there. I have a Lenovo B50-70 and wireless crashed all the time. It was active for a while on a fresh boot-up, and it just timedout after about 10 - 15 minutes or less.

What worked for me, was:

$ sudo apt-get remove --purge avahi-daemon resolvconf

You can also add new nameservers in your /etc/resolv.conf

$ sudo vi /etc/resolv.conf

Add these lines:

name server
  • Thanks god with Ubuntu 14.10 it started working properly. It was very annoying. If the problem presents itself again I'll give it a try. Thanks. – Marce Dec 9 '14 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.