-1

So I installed Steam and Dota 2 on my 13.10 Ubuntu. The game starts up and works with acceptable fps, but every 5-10 minutes or so it just freezes for 2-5 seconds. I'm positive this is not network lag since it happens also in the loading screen and in offline bot games. During these freezes my pointer can move but the in-game clock, along with everything else, stops.

I thought this was an issue with my graphics card, so I checked the drivers I was using for my AMD Radeon HD 67something: the open source drivers were on by default (xserver-xorg-video-ati), but it said the fglrx drivers were available; I tried installing those but that completely screwed over my graphic interface so I had to reinstall everything.

Do you have any idea on how to narrow down my problem (the Dota one, I've given up on the drivers)? Will be happy to provide any information needed.

EDIT: I just noticed that this also happens in Minecraft, so I think it might be an OpenGL problem...

EDIT #2: I had a look at the CPU usage graphs, it looks like during these freezes the game just stops using computing power; dunno if that's helpful...

2
  • with open source drivers you'll experience problems for sure, I have ~same thing on my pc, what I did, I set all video settings to minimum so now I don't have freezes, but the graphics are bad btw, have you tried to install these drivers manually ? these = support.amd.com/en-us/download/desktop?os=Linux+x86 Apr 5 '14 at 15:41
  • Tried installing the drivers manually, still didn't work. Had to fall back to the default ones :( Apr 6 '14 at 20:26
-1

HOW TO INSTALL AMD HYBRID DRIVERS 13.12 CATALYST ON UBUNTU 13.10

Edited: do this before installing:

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6

sudo apt-get install dkms libqtgui4 wget execstack libelfg0 dh-modaliases

sudo apt-get install linux-headers-generic xserver-xorg-core xserver-xorg-video-all libgcc1

sudo apt-get install ia32-libs lib32gcc1 libc6-i386

For 64-bits only

cd /usr

sudo ln -svT lib /usr/lib64

Install ia32libs:

sudo apt-get install libgtk2.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libidn11:i386 libglu1-mesa:i386

then remove the old drivers:

sudo apt-get remove fglrx*

reinstall the intel driver:

sudo apt-get install --reinstall xserver-xorg-video-intel

download and instlal this:

wget http://www.mirrorservice.org/sites/archive.ubuntu.com/ubuntu//pool/main/u/udev/libudev0_175-0ubuntu13_amd64.deb

sudo dpkg -i libudev*

And do the steps below:

Download amd-catalyst-13.12-linux-x86.x86_64.zip**

Extract it and you will get amd-catalyst-13.12-linux-x86.x86_64.run**

chmod +x amd-catalyst-13.12-linux-x86.x86_64.run

./amd-catalyst-13.12-linux-x86.x86_64.run --extract catalyst

cd catalyst

Apply the patch manualy:**

at the end of the file catalyst/common/lib/modules/fglrx/build_mod/kcl_acpi.c, starting with line 990, there is

#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,6,3)    
    if (!ACPI_SUCCESS(acpi_get_table_with_size(id, 0, &hdr, &tbl_size)))
#else
    tbl_size = 0x7fffffff;
    if (!ACPI_SUCCESS(acpi_get_table(id, 0, &hdr)))
...

delete everything to the end of the file and replace with this**

#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,6,3)    
    if (!ACPI_SUCCESS(acpi_get_table_with_size(id, 0, &hdr, &tbl_size)))
#else
    tbl_size = 0x7fffffff;
    if (!ACPI_SUCCESS(acpi_get_table(id, 0, &hdr)))
#endif
    {
        return KCL_ACPI_ERROR;
    }
#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,9,1)
    ((acpi_tbl_table_handler)handler)(hdr);
#else
    ((acpi_table_handler)handler)(hdr);
#endif
    return KCL_ACPI_OK;
}

Run**

sudo ./ati-installer.sh 13.251 --buildpkg Ubuntu/saucy

Change owner and group (from root to your user) for generated .deb files placed one directory up**

sudo chown <user> fglrx* and sudo chgrp <user> fglrx*

and install the fglrx* packages:

sudo dpkg -i fglrx*.deb

now run:

sudo aticonfig --initial -f

and select the discrete gpu

sudo aticonfig --px-dgpu

reboot your system

To open amdcccle, run this sudo /usr/lib/fglrx/bin/amdcccle

Source https://gist.github.com/moldcraft/8116528

3
  • Ty very much for the info, but this didn't work for me. I did everything the instructions said, without getting any error messages, but when I rebooted it was just like before: the system seemed not to recognize the driver. I did this twice to be sure, but it just doesn't work. When I type "sudo /usr/lib/fglrx/bin/amdcccle" it says that no driver is installed, although in the "Software & Updates" utility, under "drivers" it says the catalyst driver is installed. Are there any tests I could run to figure out what's wrong? Apr 14 '14 at 20:38
  • I edited the answer, try the steps listed above. Apr 15 '14 at 16:20
  • Do you happen to be in contact with a deity of some sort? I honestly wasn't even hoping it would work, but it did! The drivers are installed! I am yet to check whether the issues with dota still exist, but for now I just want to thank you! Apr 16 '14 at 23:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.