0

I am running Windows on a network that has a corporate authenticating proxy (NTLM). I have setup CNTLM and verified that it works fine with Windows.

I am using VirtualBox and have installed Ubuntu 13.10. I also changed the network proxy settings to add my Windows host as the HTTP Proxy. I am able to open Firefox and browse the public internet using the Ubuntu VM. When I turn off the proxy, I am unable to browse, so I know the proxy must be working and configured correctly.

Now, I'm trying to install node.js:

$ sudo apt-get install nodejs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package nodejs
$

When I try a sudo apt-get update, I see the following:

0% [Connecting to archive.ubuntu.com (91.189.91.13)] [Connecting to us.archive.

and it just hangs there...

Any guidance is appreciated.

2
  • Is it your first installation ? then use : sudo apt-get update first – eyadof Apr 4 '14 at 18:57
  • Do you mean sudo apt-get update? See my edited question. – Steve H. Apr 4 '14 at 19:00
1

The unable to locate package is not a network problem.

It appears if apt unable to find the package due typo or if you forget to update your package list (first time installation is included here).

But when your vm couldn't connect to ubuntu repos it seems you have not set up apt proxy you can do it by adding this line to /etc/apt/apt.conf/ file :

Acquire::http::Proxy "http://yourproxyaddress:proxyport";

1
  • I was able to do apt-get update after setting the corporate proxy host/port in /etc/apt/apt.conf. Thanks for the help! – Steve H. Apr 4 '14 at 19:59
1

This is not a GUI way of doing this, but should work: https://help.ubuntu.com/community/AptGet/Howto#APT_configuration_file_method

2
  • When I followed those instructions, I see: 0% [Connecting to hcw00139585w7 (10.151.221.171)] [Connecting to hcw00139585w7 (10.151.221.171)] [Connecting to hcw00139585 -- which is my Windows host name... Still just hangs there. – Steve H. Apr 4 '14 at 19:34
  • You will need to add your company proxy there if not doen. Maybe you should contact your IT department. – frlan Apr 4 '14 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.