0

Hi I'm a linux newbie and am having some problems with installing Gimp 2.8. I previously installed Gimp 2.6 onto my 64-bit Ubuntu 12.04 machine using Ubuntu Software Center. However, I recently tried out 2.8 and found that I like the changes and would like to install this version instead. So, I looked up how to install and tried the following method:

Uninstalled Gimp 2.6 using the following methods:

1) Uninstalled using Software Center (and uninstalled all add-ons)

I have tried the following command-line actions as well:

$sudo apt-get remove gimp
$sudo apt-get autoremove gimp gimp-plugin-registry
$sudo apt-get purge gimp*

It uninstalled fine, and was no longer listed as installed in Software Center.

Then I tried the standard method to install Gimp via terminal:

$sudo add-apt-repository ppa:otto-kesselgulasch/gimp
$sudo apt-get update
$sudo apt-get install gimp

This worked perfectly on my laptop, which now has Gimp 2.8 installed and working great. However, on my desktop I ran into a problem at the first stage of trying to add the repository.

Upon the first step (" $sudo add-apt-repository ppa:otto-kesselgulasch/gimp"), I get the following error message in terminal:

$ sudo add-apt-repository ppa:otto-kesselgulasch/gimp
[sudo] password for daniel: 
Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 8, in <module>
    from softwareproperties.SoftwareProperties import SoftwareProperties, expand_shortcut_line
  File "/usr/lib/python2.7/dist-packages/softwareproperties/SoftwareProperties.py", line 53, in <module>
    from ppa import AddPPASigningKeyThread, expand_ppa_line
  File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 31, in <module>
    import pycurl
ImportError: libheimbase.so.1: cannot open shared object file: No such file or directory

And then when I carry out the rest of the actions via terminal it installs the 2.6 version of Gimp.

Both computers are running 64-bit Ubuntu 12.04 LTS. I did look into the libheimbase.so.1 file listed a bit (it is in the /usr/lib/x86_64-linux-gnu directory) and it seems like it is absent from my Desktop (which is the one having the problems) but present on my laptop.

I don't know exactly why this problem exists, as I generally try to keep the two systems pretty similar- but it's possible I accidentally uninstalled/removed this file on my Desktop (or never installed it).

Anyway, I was wondering what exactly is happening and how I can possibly fix this so I can install the Gimp repository (and thus Gimp 2.8) on my Desktop?

Thank you!

1

So, in case anyone else runs into this problem, I figured out how to fix this. It was actually a problem with the apt-get-repository package itself, rather than something to do with gimp. So I'm thinking I must have removed the above mentioned libheimbase.so.1 file while uninstalling something else, since this seems to be a shared file/library. So I looked up the origins of this file and it's part of the package: libheimbase1-heimdal

So I installed/reinstalled this package:

sudo apt-get install libheimbase1-heimdal --reinstall

Then did the normal actions for installing the repository and gimp.

sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp

and everything is working perfectly now!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.