0

when trying to run my Laptop after suspend .

I have a black screen and nothing work. keyboard,mouse,touch bad .

My PC : Laptop Dell Inspiron 15 R

Ram :4 GB

graphic Card :Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A]

any help

  • @ElliottFrisch, swap and ram matters only for hibernation, not suspend. Ahmed, try to see if this answer helps you: askubuntu.com/a/436389/16395 .Otherwise, yuo really need to edit your question adding details (type of PC, graphic card/drivers, etc.) – Rmano Apr 4 '14 at 15:45
  • Romano,I tried every thing in this post. but no new . – Ahmed Apr 4 '14 at 16:21
  • Try to see if there is some hint in the file /var/log/pm-suspend.log --- maybe an error or device that got stuck. Are you using open-source drivers for the graphic card or the proprietary ones (fglrx)? – Rmano Apr 4 '14 at 16:59
  • pm-suspend.log file content /etc/pm/sleep.d/novatel_3g_suspend suspend suspend: success. Thu Apr 3 15:51:07 EET 2014: performing suspend \00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00 commandline parameters: Thu Apr 3 16:39:13 EET 2014: Running hooks for suspend. Running hook /usr/lib/pm-utils/sleep.d/000kernel-change suspend suspend: – Ahmed Apr 4 '14 at 21:49
  • Sorry, no idea (BTW, it is much better to add info to the question --- formatting in comments is quite limited). – Rmano Apr 4 '14 at 22:09
0

Actually there is a bug which you can find in Launchpad.net

Best thing is that there is also a patch through which you can solve this issue.

Follow these steps hope it works for you also:

Open terminal and execute these steps:

1 - Backup old settings

sudo cp /etc/default/grub /etc/default/grub_back

2 - Open file to edit

sudo gedit /etc/default/grub

3 - Replace the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force"

4 - Save the file Ctrl+S and close Ctrl+Q

Note: The next line to the line mentioned above should be GRUB_CMDLINE_LINUX="" not GRUB_CMDLINE_LINUX="acpi_osi=Linux"

5 - Now execute following command to update the grub

sudo update-grub

Re-start your system once.

Note: If you have trouble in brightness also and above method doesn't fix it then you can test by adding these lines in place I mentioned above.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

or

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor pcie_aspm=force"

or

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

or

GRUB_CMDLINE_LINUX_DEFAULT="pcie_aspm=force"

or

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"

Note: You have to do a sudo update-grub and a system restart every time you change the grub file

Different system would need different options, if any of the option works, I request to mention that in the comment.

6 - Edit/create the file

gksudo gedit /etc/pm/sleep.d/01_switchvt

7 - copy and paste this code and save

#!/bin/sh

# Switch to a VC before suspending and back after resume

case "$1" in
        resume|thaw)
            chvt 7
        ;;
        suspend|hibernate)
            chvt 1
        ;;
esac

8 - make it executable:

chmod 755 /etc/pm/sleep.d/01_switchvt

sources: https://askubuntu.com/a/387676/265172 and https://askubuntu.com/a/361706/265172

  • now ubuntu working after suspend, but I have another problem because of using this Command GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset".. My Graphic Driver Not working – Ahmed Apr 9 '14 at 23:11
  • run $ sudo aticonfig --initial – Enrico Mendonca Apr 15 '14 at 16:27

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.