This question already has an answer here:

I have a Dual Boot with Windows 7 and Ubuntu. Using Disk Management in Windows, I deleted the Ubuntu partition, but when i restart my computer, I'm getting Grub Rescue Command.

I Tried ls (hd0,msdos6) and when I type insmod normal, it says file not found.

marked as duplicate by WinEunuuchs2Unix, Zanna, Eric Carvalho, user364819, Sumeet Deshmukh Jun 12 '17 at 2:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


You need to re-install the Grub using the instructions mentioned here:- Grub Install

Afte fixing the boot issue you can go ahead and you can remove Grub by referring the link:- Remove Grub

  • I corrupt a 12.04 install overwriting it with a 16.04 and the provided "Grub Install" link worked first try with no errors (windows and mem-test partitions intact). – samis Jun 9 '17 at 1:58

This happens when you have faulty or old version of BIOS which can't handle large files. So you need some external third party software to resolve the issue. I would recommend you to make bootable usb for Boot-Repair or Rescatux(I recommend this).You can easily find them by searching. A link from sourceforge for boot-repair https://sourceforge.net/projects/boot-repair-cd/ and Rescatux https://sourceforge.net/projects/rescatux/ They may help in fixing the lost grub path or installing a new grub if you want.

Not the answer you're looking for? Browse other questions tagged or ask your own question.