3

When i'm playing a 5.1 movie, i only hear left and right channel. When there's sound from a rear channel, i hear absolutely nothing.

How do i set VLC to convert 5.1 to stereo, so that no sounds are missing?

PS I use PulseAudio.

2

The two ways I have found until now are:

  1. to downmix the audio stream with an external utility (like eac3to at least on Windows), but the quality is not always good enough.
  2. use VLC version 2.1.3 or higher. http://www.vlc-forum.de/index.php/Thread/1423-Audio-5-1-Spur-zu-Stereo-Spur/ [in German] someone says that VLC downmixing became better.

http://www.hydrogenaud.io/forums/index.php?showtopic=104214 shows that it is not possible to automatically downmix something with perfect quality - it seems that an audio engineer who corrects the volume of each channel is needed in some cases like yours.

| improve this answer | |
0

I'm using the WaveOut audio output under Preferences > All (Advanced) > Audio > Output Modules.

  1. Disable Dolby Surround in Preferences > Audio > Dolby Surround to Off, and uncheck Headphone surround effect, if checked.

  2. Under Preferences > All (Advanced) > Audio > Output Modules > WaveOut > set the Audio output channels to 2.

  3. Save and restart VLC.

Please note that Disabling Dolby Surround didn't have any effect, but changing the output channels down to 2 did, so I left it off.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.