I have the following error:

Kernel driver not installed (rc=-1908)

Please install the virtualbox-ose-dkms package
and execute 'modprobe vboxdrv' as root.

This forbids me to launch any virtual machine. I checked and I already have the virtualbox-ose-dkms package installed. As a matter of fact I reinstalled it too, but it did not solve the problem.


Looks like you had an update on virtualbox and because of that, its kernel module wasn't recompiled (that's why it wants you to install the dkms package).

I don't know if you're running the open source version of virtualbox, but usually running this command:

sudo /etc/init.d/vboxdrv setup

solves the problems.

| improve this answer | |

Because of useful and regular updates it is recommended to install and run Virtual Box from the repository maintained by Oracle. For avoiding to manually update the kernel driver on every update DKMS Install dkms is useful.

See also this answer for details on the installation of Virtual Box.

| improve this answer | |
  • I had the same issue last night whenever I run VirtualBox. I originally installed VirtualBox from Ubuntu Software Centre. I have removed it, installed VirtualBox from Oracle and the issue has been resolved. VirtualBox is now running smoothly. – Mike Nov 22 '11 at 2:34

I had precisely the same error. Running virtualbox from the command-line gave the following error:

WARNING: The character device /dev/vboxdrv does not exist.
     Please install the virtualbox-ose-dkms package and the appropriate
     headers, most likely linux-headers-generic.

     You will not be able to start VMs until this problem is fixed.

Consequently, I did the following and it solved the bug:

  1. install the latest open-source version of VirtualBox as explained here. Nonetheless, this step does not seem essential.
  2. install the appropriate generic kernel header. As for me it was linux-headers-2.6.38-8-generic. To know the version you need, you should type uname -r in a terminal.
| improve this answer | |
  • The closed-source VirtualBox is not needed, installing the headers is enough (related answer) – Lekensteyn Jul 23 '11 at 9:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.