2

I've just installed Ubuntu 14.04, I'm not sure if Radeon Dynamic Power Management is working because the laptop is hotter than my previous Ubuntu 12.04.4 with kernel 3.11 plus adding the kernel parameter "radeon.dpm=1" added in line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash".

Please, could someone confirm that DPM is active out of the box in kernel 3.13?

  • You can check if DPM is working from the terminal by running: sudo cat /sys/kernel/debug/dri/64/radeon_pm_info. Source: askubuntu.com/questions/324733/… . Also the info about DPM might be in a different directory. Read the link for more details. – karel Apr 3 '14 at 12:13
  • 1
    Thank you for your response!! :D After seeing your comment I've added the kernel parameter "radeon.dpm=1" as I did with kernel 3.11 and know the laptop is cooler. Furthermore, I've checked using the prder that you suggested me and the return is:uvd vclk: 0 dclk: 0 power level 0 sclk: 20000 vddc_index: 2. So I think that DPM is not enabled by default in Ubuntu 14.04. Perhaps because it's still in beta, I don't know. Anyways, thank you very much for your help and very best regards!! :D – user44849 Apr 3 '14 at 12:55
3

It is enabled by default on kernel 3.13 on Ubuntu 14.04 LTS. Tested with the above "dmesg | grep radeon" after reboot and voila:

[drm] radeon: dpm initialized"
| improve this answer | |
2

Personally I dislike adding options to modules via the GRUB command line. Instead, to enable DPM with my Radeon card I created a file /etc/modprobe.d/radeon.conf with the following contents:

options radeon dpm=1

After creating this file it is necessary to rebuild the initramfs in order to apply the changes:

$ sudo update-initramfs -u

After the next reboot, the dmesg contents show that the option has taken effect:

$ dmesg | grep radeon
... various other output ...
[    2.439073] [drm] radeon: dpm initialized
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.