2

So I installed ubuntu. And a little time it continues - i could to load windows from grub, and all was right.

But something happened and now when I choose Windows 7 x64 on my grub list It says that cant find my Windows bus i see my Windows folders on my hard disk (that is all right).

I have updated my grub, Windows string disappeared.

As I understand, i need to find the way to windows loader, and write it to any config file in my grub configuration. But it is only theory. Help me please. How to recover Windows in my GRUB.

Ubuntu is installed to other disk than windows, so it is separated. Also I had checked file system status in my ubuntu disk utility - it says that my file system (where 7 installed) is damaged. I don't know how to care it.

UPD: output of sudo fdisk -l:

Диск /dev/sda: 320.1 Гб, 320072933376 байт
255 головок, 63 секторов/треков, 38913 цилиндров, всего 625142448 секторов
Units = секторы of 1 * 512 = 512 bytes
Sec size (log/phys): 512 байт / 512 байт
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk id: 0xf2efcaf5 

Load dev. Beg       End       Блоки     Id Система 
/dev/sda2    206848 599878722 299835937+ 7 HPFS/NTFS/exFAT 
/dev/sda4 599879678 625141759  12631041  5 Расширенный 
/dev/sda5 621045760 625141759   2048000 82 Linux своп / Solaris 
/dev/sda6 599879680 621043711  10582016 83 Linux

Boot Repair logs:

  1. Initial.
  2. After doing Custom Repair.

UPD: Executed bootrec /fixboot in system repair. Windows string appeared again. But can't load: error of type 000000xc000000000 end to 428

4
  • Please add more details about the filesystem. I recommend to paste the output of the command sudo fdisk -l example Apr 3, 2014 at 6:37
  • The best way to add additional information to your question is by editing it, with the edit button. It is better visible that way, and comments are mainly for secondary, temporary purposes. Comments are removed under a variety of circumstances. Anything important to your question should be in the question itself.
    – Danatela
    Apr 7, 2014 at 9:12
  • ok! understood. Apr 7, 2014 at 16:42
  • 1
    All your Boot-Repair links show no BCD in a /boot partition in Windows. You may have had a separate Windows boot partition in sda1 which is now missing. You need to run Windows repairs to add BCD. BootRec.exe /RebuildBcd
    – oldfred
    Apr 8, 2014 at 3:50

2 Answers 2

0

You should boot from your Windows installation media (either DVD or USB) and select System Recovery. Then select Command Prompt.

In the window, you have to run

chkdsk /F C:
bootrec /fixboot
bcdboot C:\Windows /s C:

You should now make the partition active.

diskpart

DISKPART> select disk 0

selected disk 0

DISKPART> select partition 1

selected partition 1

DISKPART> active

partition 1 marked as active

Your partition number may differ from mine so run list partition before you select it. And if you select wrong partition, you can destroy Ubuntu, so be careful.

Then return to System Recovery Options and select Startup Repair. Then you can boot Windows from it's disk, but it's not the goal. You should now reboot to Ubuntu and run in the Terminal:

sudo update-grub

This should find Windows and place it's entry inside GRUB menu.

5
  • I tried. I captured that commands you showed to me. So now then Win 7 sting appeared again in grub, i cheese it but my win 7 cant load - it has an error. ps My win 7 was modified by boot screen and I also used slic activator by daz. Apr 4, 2014 at 17:21
  • Yes I tried to repair it from usb windows pe, but it just killed my grub, so i recovered grub. It cant see my system but i see it in nautilius. So may be someone can help me use remote desktop? Apr 7, 2014 at 8:58
  • Now use Recommended Repair option
    – Danatela
    Apr 7, 2014 at 16:53
  • Before installation there was 2 disks 1. system C: ~300gb 2. system D: recovery (oem) ~13gb So i decided to destroy D: and separate it -9gb for system and 4 for swap When I installed Ubuntu all worked good. But I forget to manage free space for ubuntu and waste coming soon. as i said at the first time I created 9gb for this sustem, and 4 for swap so using gparted from usb i cut swap to 2gb and plus to system. But soon i understood that it is not enough. I decided to cut from C: so a loaded windows 7 and tried to cut free space/ But something happened... i dont know what. Apr 7, 2014 at 16:57
-3

Based on my experience I found that if you have Windows/Ubuntu dual OS, it is always easier to use the windows boot loader instead of GRUB. You can install EasyBCD in windows and use it to manage the bootloader. It is a free software. If you cannot boot into your local windows right now, try Win PE in a bootable USB drive.

2
  • More details please, which versions have you used and was it on an MBR or UEFI system? Apr 3, 2014 at 6:38
  • I think I used MBR Apr 4, 2014 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.