How can I have 2 rows and 3 columns of desktops in Lubuntu? (Instead of having 1 row which is the default setting.) I haven't found a setting, yet.


With LXDE the fine adjustment of desktop appearance is reduced as compared to other non-light weight desktops. Therefore by using Desktop Pager for workplace management you will only be able to set the number of desktops but not their appearance in rows and columns.

Still, if you desperately need this there is a way to disyplay 2 rows of desktop icons in the panel by increasing the panel height from the Panel Settings (right click on the panel to open) to a value of lager than 40 pixels:

enter image description here

To toggle between workspaces when moving the mouse to the screen borders you may be interested in brightside Install brightside that is called with the command brightside from a terminal or by putting in autostart.


sets the application's options.

| improve this answer | |
  • Brightside is a great suggestion! – OrangeTux Aug 22 '12 at 6:42

There is a CLI that allows you to arrange the layout of your workspaces in LXDE. Unfortunately it doesn't update the mini-map in the panel -- the panel still displays one row of workspaces (Takkat's answer affects the panel, but I don't like the overall effect on the rest of the panel.)

Here's the answer over on Superuser: https://superuser.com/questions/347528/openbox-make-4-desktops-2x2

To recap (and expound on) the solution here:

  1. In the Openbox Configuration Manager, set your total # of desktops (e.g. 6)
  2. Go to tmp dir: cd /tmp/
  3. Download setlayout.c: wget http://openbox.org/dist/tools/setlayout.c
  4. Install dependencies: sudo apt-get install libx11-dev
  5. Compile it: gcc setlayout.c -o setlayout -lX11
  6. Copy it to /usr/local/bin as you'll need to run the setlayout command after reboot: sudo cp setlayout /usr/local/bin
  7. Set your layout geometry: setlayout 0 3 2 0 (for a 3x2 grid)

With this grid setting, CTRL-ALT-<Arrowkey> navigate properly. Here's the workspaces with a 2x2 layout:

Workspace switcher notification icon

And dragging windows across workspaces with the mouse (or with Alt-Shift-<Arrowkey>) works as expected (up/down/left/right)

FYI #1 The program prints usage help if four args aren't passed:

The first is layout, 0 is horizontal and 1 is vertical.
Second and third is number of desks horizontally and vertically.
The last is starting corner, 0 = topleft, 1 = topright,
                             2 = bottomright, 3 = bottomleft.

FYI #2 Alternate download link for setlayout.c: http://hastebin.com/pizabalefo.tex

FYI #3 When changing the layout later to a different number of desktops, first set your layout back to a single row (e.g. 1x6) using setlayout 0 6 1 0 before opening the configuration manager, or it may crash.

| improve this answer | |
  • The setlayout tool shows a grid in the notification widget, but the up/down shortcuts don't work for me, only the left/right, as if they were all in a line. Strangely, I can drag windows to the workspaces up or down, but the shortcuts don't work. – Pedro Werneck Dec 29 '16 at 3:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.